Custom URL not working

I have this problem connecting to cameras after a reboot of Netcam Server 1.5.5.
I cannot find the cameras using “Network Camera”,“ONVIF Source” or “Custom URL”. Tried to delete cameras and re-enter the custom URL (which I use) without any luck.
I’ve tried with VLC and it work perfectly with the same URL.

Any suggestins where to start troubleshooting?

(NOTE: Masked out the user:pass on the link)

Event Log:

At least it is consistent on all cameras :slight_smile: The URL´s are there and of cause it should work …By reboot you mean EXIT NCS and then start again? EXIT with the red X. Go to Task Manager and see if there are any NCS processes running. If there are kill them. Start NCS again. Also the official release is now version 1.5.6 Netcam Studio 1.5.6

Hi Henrik,

I mean restarting the entire machine. No Netcam process is running prior to starting the server application.
I’ve tried both running the service and the executable file. No difference, same problem.


Hi again,

Seems like a found a workaround regarding this issue. I had to choose under “Custom URL” -> “Stream Type” and select “JPEG”, click OK (check symbol) and then go back in again and select “Stream Type” -> RTSP_TCP, then click OK again.
Simple solution, but annoying bug.

Se below for pics:


Certainly agree. Either it is the saving process when Exit or the reading process at start.
@Steve have to check was is going on.
Thanks for your efforts!

I will check when:

  1. Log files are provided
  2. We have steps to reproduce the problem

Here if it’s isolated on one system and we don’t know how to end up in the situation there isn’t much that I can do…


Got the same problem yet again after a restart.

What kind of log do you need, and what of additional info do you need in order to investigate this issue?

This happen right after a clean restart. No additional updates, programs or services was installed or tapered with.

Some system info:

Running on a VMware host running 6.5d, server OS windows server 2012 R2.
ESXI host running 64Gb RAM 2 physical CPU AMD Opteron 4228 HE @ 2.8Ghz
OS running on 2 phy CPU @ 2.8Ghz with 20Gb or RAM.

Remote access is available upon request.

Regards Mads

Really annoying! With a clean start you mean that you stop the service, start the service again and connect with the windows client? When this happens and you do this procedure again it ends up with the same result or does it work the second time?
Can you run the NCS X Server instead and enable the logging. It is easier to see what is going on there.
The 6 cameras seems to be of the same brand/model according to the URL´s? What cameras is it? I am getting a little suspicious since in the URL it says unicast is true. Where did you find that URL?

Hi Henrik,

Thanks for quick reply.
With clean start I mean;

  1. rebooting the server
  2. the service (Netcam Studio Server (64-bit) starting with no delay and proper account for writing to NAS.
  3. starting the Netcam Client on a different computer (physical).

Stop and restarting the services gives the same result, no difference.
The same problem persist when I start the .exe file instead of using the service.

My cameras is Dahua branded. From 1080p to 4k cameras. Using same URL on all of them without any issues.
I use ONVIF Device Manager to fetch the URL. I’ve tested this URL with both VLC and ONVIF DM and it work prefectly.

I’ve started the .exe server, checked the “Save Event Logs tro file”. But where is the log files located?


Did some sniffing on the server as well. Seems like the server sends a TEARDOWN to the camera for the RSTP. Not sure why this occurs.
This capture is done using TCP, but the same happen with TCP.

After the teardown, the server tried to re-establish the connection with no errors (it seems like…)

Cap file:
Wireshark Capture

Thanks. Depending on the model the URL is a bit different, but can you try these first in VLC so it works for the specific camera and then use the same in NCS.

Power off/on the camera first also if you can.


Logfiles are in C:\ProgramData\Moonware\Netcam Studio\Server\Logs


Yes the log files we need are the ones from netcam studio (requires logging to file to be enabled).

TEARDOWN command is to notify the camera that we close the connection, netcam studio is sending this command when connection to the camera is lost or when stopping the app / service properly.

Some cameras may refuse new TCP connections until:

  1. there is an internal timeout / period without any connectivity
  2. the camera is reset
  3. sometime if another url / stream is pulled then it will reset the connection)

Maybe in your case only 2 and 3 applies, i don’t know how the camera works internally but it looks like it is refusing the connection. Probably OnvifDM is doing something that puts it back on track.

My little dlink that I use 24/7 had problems with this but they fixed it by firmware updates to make it more robust / solid and since i never had issues anymore.


I’ve restarted all the cameras (power on/power off). Tried all the links provided by Henrik, no difference.
I got 5 cameras, but 3 different models (different firmware).

Cam1 - IPC-HDBW4421R-AS - 2.600.0005.0.R, Build Date: 2016-12-19
Cam2 - IPC-HDBW4233R-AS - 2.420.0000.22.R, Build Date: 2016-12-09
Cam3 - IPC-HDBW4421R-AS - 2.600.0005.0.R, Build Date: 2016-12-19
Cam4 - IPC-HDBW4233R-AS - 2.420.0000.22.R, Build Date: 2016-12-09
Cam5 - IPC-HDBW4431R-AS - 2.420.0000.22.R, Build Date: 2016-12-09

Attaching the logs files for further investigation.

Netcam Logs


if you use this exact url:

in VLC it works ?

Because what could be here is that this doesn’t work if prior to this it hasn’t been an onvif authentication done by ncs. Just a guess but this problem seems very specific to your camera.


Yes. This works well in VLC. No problems at all.

Send me a PM if you want remote connectivity to troubleshoot.


Just a test.
Can you add this one IPC-HDBW4421R using MJPEG instead

Stream Type is MJPEG

There are several Templates for Dahua in Network Camera. Test there with mjpeg. It is not the same models, but dahua use the same url for many models.

Hi Henrik,

I’ve tested with MJPEG, but still getting “Connection Failed”. I can try once again to set up a new server since I haven’t activated the license yet.


This was the result I was hoping for. Something else is wrong here. If you have another computer set up NCS on that one. Just test with one camera. On this server uninstall and delete also all files in ProgramData>Moonware and in ProgramFiles> NetcamStudio and make a clean installation.

When you exitt ncs go to task manager and make sure that there are not ncs processes running. If so end them! Start ncs again.


Installed the x64 server on another computer. Works fine on this one. Win 7.

Reinstalled the server. Deleted all old references and it’s now working again.
Thanks to Henrik and Steve for assisting in troubleshooting.