Download Previous Versions


Is it possible to download previous versions of Studio?

Everything was working fine on version but when I installed the Client today on a separate machine I couldn’t connect to the server. I thought the issue may have been the mixmatch of versions but upgrading the server to has caused all sorts of errors.

Am I able to download so I can begin diagnosing what the problem is?


Unfortunately we do not provide older versions.

v1.0.2.0 suffered from a security problem that we had to fix quickly so it’s anyway not suggested to use this version any longer.

Netcam Studio Client may have broken features if not running the same version that the server and should warn about it when started.

You can report the detail of the problem you have with 1.0.5 in case you still face troubles.


Thanks for the reply.

I installed v1.0.5.0 on a Windows 8 workstation and that seems to work fine so I don’t believe there is any fault with the software.

My original V1.0.2.0 was running on a Windows 2008 server, everything has been working perfectly until I upgraded to v1.0.5.0.

I have tried un-installing all the software and manually removing all the directories, c:\program files, c:\ProgramData, roaming \ local profiles etc and re-installing but I still cannot get it to work.

For example, if I tried to add a new source I am unable to view or select any make, model of cameras, something that works on the Windows 8 installation.

From what I cann see all the Visual C++ install files are there, 2005, 2008, 2010, 2012 & 2013 are installed on my server. I’ve looked through the event logs & the Studio logs but I can’t see any errors anywhere.

I’m sure this is a conflict somewhere but as yet I haven’t found it. This is what I wanted to try the old version just to see if it’s something specific to the newer version or which would at least help with the process of elimination.


Are you using Netcam Studio Service or Netcam Studio X ?

Try stopping the service and use exclusively Netcam Studio X first and ensure it behaves normally.

If you use Netcam Studio Service (and Client) and they have troubles communicating (typically no brand / templates) it’s usually because it’s not the same version of Server and Client.

I will test to ensure that Client 1.0.5 and Service 1.0.5 do not have something wrong regarding web services contract which can also result in similar issues.

If you have the problems with Netcam Studio X 1.0.5 then please collect the log file of the day in

C:\ProgramData\Moonware\Netcam Studio\Server

and send it by email to the technical support (or host it somewhere temporarly) so that I can have a look, normally there is always errors generated but in your case it’s probably on the client side (logs are in C:\ProgramData\Moonware\Netcam Studio\Client).


I have tested Service + Client both running 1.0.5 in 32-bit and 64-bit and no there doesn’t seem to be any contract mismatch.

Could be due to .config file but if you have already cleaned c:\program files manually there is no reason that you would still have an older version.

But if anything goes wrong from the Event Logs (in Netcam Studio Client or X) you should be able to see a Warning or an Error telling a bit more about the problem…