Error with RTSP camera

I’ve got a network camera the fortunately uses the RTSP protocol. I can use VLC to look at the stream all day with no problems. No matter which option I try under the generic camera I get the same error:

Netcam.WorkerThreadLibAV() Thread Finished…
Audio Failed with error: Not Tested

I’m running the latest version of the 32 bit version of Netcam Studio. When I run the 64 bit, I get this error:
Video Failed with error: No Suitable Library was found to play the video stream. Try Installing VLC 64-bit or use Netcam Studio 32-bit instead.

As far as I can tell, I am using VLC 64 bit on my machine. How do I fix this?

If VLC is installed then netcam studio will use its library to decode RTSP streams.

When using the custom url. do you provide the credentials in the url ? In VLC, it will prompt for them, in netcam studio they must be provided this way:


Most likely VLC-64 is not installed or you wouldn’t get this message.Where is your VLC installed ?

C:\Program Files\VideoLAN or C:\Program Files (x86)\VideoLAN

Ensure that you use VLC 2.1.5 or VLC 2.2.0 which are the 2 versions that we have tested and support.

1 Like