Fentac V380 Connection


Did anyone find out how to use the PTZ function in the V380?



Check if the camera with latest firmware support onvif. If so, add the camera using the onvif tab.


My camera says it is a V380E and firmware is very new, think it was may 2017 but still cannot connect using ONVIF although ONVIF manager finds it.
I am in the exact same position as Brandin A. and have never found any PTZ solution online. PTZ only works with V380 app on my iphone and MVCMS_lite on PC.


V380 stream url

Same here. Something new?


If ONVIF device manager detects the camera follow the part about adding ONVIF to NCS in this post


Thanks for answering.
I found the solution after talking with the support team of these cameras. It is necessary to upgrade the firmware of the camera to open the onvif ports.

1.- Unzip the files
2.- Copy the files to the root of the microSD
3.- Restart the camera
4.- Wait until the update finishes, listening if you have a horn or watching the LEDs
5.- Check that the ports have been opened
6.- Delete the SD update files

Upgrade Files:

V380 stream url

Excellent! Thanks for sharing. I think this will avoid lot of headaches :slight_smile:


Thanks for the solution @sk8darr!

I’m also happy to see how much exposure this thread has gotten from the users who use V380, and hopefully started using this amazing software they didn’t realized existed!

Thanks again @Henrik for your help around here as always.




i have tried this steps but problem is not solved,
anyone still having this problem ?
can i get the technical support contact ?

thank you,


I have a webcam of the same make (Shenzen Bilian Electronics) and scanned the ports using Angry IP scanner. I found that on my device (the 360EYE), the ONVIF port is 8899. There are also open ports on 5040, 5050, 5051, 7050 and 8800.


That link doesn’t seem to be working anymore, can you repost please?



Hi. I just verified the link and it continues to work correctly. It is a file on Google Drive with a link shortener. Just wait a few seconds on the redirect page and then click on the remove advertising button. Then it will take you to Google drive and it will tell you that you can not open the file but you can download it. You download and ready


Hi can i get technical support contact? I have tried the file and steps without success


In the postings above you can read what I (Netcam Studio) know about this camera. Contact users in the forum for assistance.




Good luck

Ing. Angiello Rivas

How to access V380 camera on browser and RTSP

Until I update the firmware nothing worked for me.
Now it’s OK with
I can connect via VLC player.


Has anyone tried this firmware update with unbranded camera? Bought one from Lazada and it uses “v380” app so pretty sure this camera comes from the same manufacturer.
ONVIF device manager (super!!!) does recognize the camera but can’t show any live video or live stream (“NO SIGNAL”).

System kernel version:
System firmware version:

So it seems quite old firmware. If trying to update it via the mobile app it says this is the newest version.


As I was afraid to use the upgrade file on my camera i just checked the script inside and it seems it adds has_rtsp=1 into the /mnt/mtd/authority.ini
(The script also copy some files from /tmp which i am afraid might corrupt my camera as there are completely different files in the tmp folder than in original folders now)

But even if imanually modified the authority.ini file by telnet, i am not able to connect via rtsp.
Can any of you who can connect check if the port 554 has been opened using the upgrade file?
It’s still closed on my cam.

If I telnet into the cam (using the user root without any password) i can only see following ports open:

[root@V380E ~]$ netstat -tuplen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 479/recorder
tcp 0 0* LISTEN 761/as9nvserver
tcp 0 0* LISTEN 761/as9nvserver
tcp 0 0* LISTEN 373/telnetd
tcp 0 0* LISTEN 479/recorder
tcp 0 0* LISTEN 761/as9nvserver
tcp 0 0* LISTEN 761/as9nvserver

My authority.ini file looks like this:



I also got a AK3918+SC1245 Mini IP Camera V380E
System app Version: AppV380E12_PCARD_V50_V2.5.5.2 20180901
System kernel Version: KerV380E12_PCARD_V50_V2.2.0 20160506
System firmware Version: HwV380E12_WF3_PCARD_V50 20160217

Ports 23(Telnet) and 554(rtsp) were closed.
Thanks to update posted by @sk8darr port 554 is open and RTSP is working and port 23 was open only til next reboot.
If you apply the update again - Telnet port will open again til reboot.
Unfortunately I could not login, so I modified the update to provide root shell on telnet
Unzip and copy files to an empty SD card . Use it on your own risk.


I used the updatepatch on my ipcam to enable telnet & rtsp and it worked perfectly, I dumped the configs from the filesystem and fiddled around with it and seem to have locked myself out.

I changed ‘/mnt/mtd/nvipcstart.sh’ changing ‘debug=0’ to ‘debug=1’ in the hope of removing the cloud functions but the camera is unresponsive on the network now. I can still apply the updatepatch so I tried modifying it to revert back to ‘debug=0’ but the update says it failed. I changed the md5 hashes correctly as others above done, but when saving the patch gedit warned me about possibly corrupting the document as its in a different encoding and im guessing thats what happened.

the line I was trying to add was:
sh -c “sed -i ‘s/debug=1/debug=0/g’ /mnt/mtd/nvipcstart.sh”

perhaps maybe @smashin or @sk8darr could help me, how can I edit this file in gedit without the warning about invalid characters and encodings