Fentac V380 Connection

In the postings above you can read what I (Netcam Studio) know about this camera. Contact users in the forum for assistance.



Good luck

Ing. Angiello Rivas

Until I update the firmware nothing worked for me.
Now it’s OK with
I can connect via VLC player.

1 Like

Has anyone tried this firmware update with unbranded camera? Bought one from Lazada and it uses “v380” app so pretty sure this camera comes from the same manufacturer.
ONVIF device manager (super!!!) does recognize the camera but can’t show any live video or live stream (“NO SIGNAL”).

System kernel version:
System firmware version:

So it seems quite old firmware. If trying to update it via the mobile app it says this is the newest version.

As I was afraid to use the upgrade file on my camera i just checked the script inside and it seems it adds has_rtsp=1 into the /mnt/mtd/authority.ini
(The script also copy some files from /tmp which i am afraid might corrupt my camera as there are completely different files in the tmp folder than in original folders now)

But even if imanually modified the authority.ini file by telnet, i am not able to connect via rtsp.
Can any of you who can connect check if the port 554 has been opened using the upgrade file?
It’s still closed on my cam.

If I telnet into the cam (using the user root without any password) i can only see following ports open:

[root@V380E ~]$ netstat -tuplen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 479/recorder
tcp 0 0* LISTEN 761/as9nvserver
tcp 0 0* LISTEN 761/as9nvserver
tcp 0 0* LISTEN 373/telnetd
tcp 0 0* LISTEN 479/recorder
tcp 0 0* LISTEN 761/as9nvserver
tcp 0 0* LISTEN 761/as9nvserver

My authority.ini file looks like this:


1 Like

I also got a AK3918+SC1245 Mini IP Camera V380E
System app Version: AppV380E12_PCARD_V50_V2.5.5.2 20180901
System kernel Version: KerV380E12_PCARD_V50_V2.2.0 20160506
System firmware Version: HwV380E12_WF3_PCARD_V50 20160217

Ports 23(Telnet) and 554(rtsp) were closed.
Thanks to update posted by @sk8darr port 554 is open and RTSP is working and port 23 was open only til next reboot.
If you apply the update again - Telnet port will open again til reboot.
Unfortunately I could not login, so I modified the update to provide root shell on telnet
Unzip and copy files to an empty SD card . Use it on your own risk.

1 Like

I used the updatepatch on my ipcam to enable telnet & rtsp and it worked perfectly, I dumped the configs from the filesystem and fiddled around with it and seem to have locked myself out.

I changed ‘/mnt/mtd/nvipcstart.sh’ changing ‘debug=0’ to ‘debug=1’ in the hope of removing the cloud functions but the camera is unresponsive on the network now. I can still apply the updatepatch so I tried modifying it to revert back to ‘debug=0’ but the update says it failed. I changed the md5 hashes correctly as others above done, but when saving the patch gedit warned me about possibly corrupting the document as its in a different encoding and im guessing thats what happened.

the line I was trying to add was:
sh -c “sed -i ‘s/debug=1/debug=0/g’ /mnt/mtd/nvipcstart.sh”

perhaps maybe @smashin or @sk8darr could help me, how can I edit this file in gedit without the warning about invalid characters and encodings

Sorry to double-post but I just wanted to add that ive got the patch to apply successfully according to the voice playback at least. (needed editing in a hex-editor to preserve the header at top of file) but the camera still seems to stop after “system is starting” message. I’m sure that setting ‘debug=1’ in /mnt/mtd/nvipcstart.sh was my error and it should be reverted now but I cant get back in, does anyone have any ideas how i can get the camera online again?

@thecosmicslug Header contains the length. Try replacing in update file without modifying it’s size. After that calculate the checksum and apply the patch again.

Finally I succeed to open RTSP stream on my pretty old Fedora-17 box. I couldn’t get VLC up running, but it turned out that TOTEM Movie Player has RTSP support built-in. All you need to do is : Movie -> Open Location … and enter rtsp://user:pass@ip-address/live/ch00_0 or rtsp://user:pass@ip-address/live/ch00_1
Replace user,pass and ip-address with your values.

I got a new €15 camera that uses the V380 app and lack all other ways of accessing it. It is a totally round small camera that are supposed to hang on a wall. It had version PCARD_V50_V2.5.6.2 and I used the patch file on it and it worked to open up a RTSP stream.

Thanks for sharing the file and solution to others!


1 Like

First Patch is also working with light bulb camera (that works with v380 android app). Thanks for sharing the solution!!
RTSP works fine,
Telnet works but password is not known
Maybe also ONVIF can be exposed, I’m trying to learn how
I’m not familiar with that patches but maybe it’s also possible to copy the password file to the sdcard, or set a new root password, or add a new user.
My cam has also a light that can be turned on/off from the android app, I’d like to control it via pc. I’ve found decompiled v380 app (https://github.com/brusdev/V380-SDK) but I haven’t already found how the light is managed (I suppose is controlled like a ptz). Grabbed some network data but nothing easily readable.

Ok, with second patch (from smashin) i can logon in root shell.
Found how to turn-on/turn-off/read-state of the camera led:

/mvs/apps/gpiotest 10 r --> reads led status
/mvs/apps/gpiotess 10 w 1 --> turn on leds
/mvs/apps/gpiotest 10 w 0 --> turns off leds

Now i’m searching a way to make that commands reachable externally… Maybe http or mqtt or tcp


I’ve a Q6 v380 smart net camera.
Thanks for the second patch, it’s works fine, telnet and rtsp.
Is it possible to move the camera with rtsp ?

Hi, I’ve applied the second firmware update to my V380 camera and now I can connect to it through RTSP 554 and telnet ports. But there is no password to the streaming access.
Is it possible to change the admin password?
If so, how?


thanks to you all.
finally i can capture my camera using vlc media player.
but i can open from browser. and i need the darkmode.
can i capture in darkmode ?

What is the URL in VLC?

Now I have another camera that uses the V380 plattform and it has firmware HwV380E23_WF3_PTZ_ETH
It’s totally unresponsive to everything except the V380 app. The patch file didn’t work as it checks what FW version the camera has and this one are not compatible.

Anyone got E23 version to work with rtsp?


I too would like to know how to enable some password on the RTSP server if anyone knows?

Hi @sk8darr, do you know if this upgrade works for VESKYS cam? I bought this one https://www.gearbest.com/ip-cameras/pp_009429741294.html and can’t access with rtsp and telnet.

Thanks in advance!