Fentac V380 Connection

ok, I got RTSP working with ceshi.ini , but now RTSP stream is available with any password. Can you please confirm that you see this too?

Great thread!
I followed the instructions to open rtsp on a v380 Panoramic (light bulb) cam.
Did anybody manage to find a solution for start/stopping the LEDs remotely (besides using the iOS/Android apps)?
If I manage to do this this camera is a keeper.

Hi,
I have the same camera with rtsp working but with the same concerns:

  • No password to access to the streaming.
  • How can I be sure the camera is not accessible from the outside or is sending anything to the outside?

I blocked the device in the router, so it should no be able, but…I want to be 100% sure

Sorry, there is nothing like 100% in this business :slight_smile:
You can install Wireshark. There you can monitor the traffic from/to the camera.
If you really are that concerned maybe you should buy a camera that you do not need to crack to get to work and that also use a password of your choice.
-Henrik

Hi all IP-cam maniacs :wink:

I try update V380 but I find this very difficult.

Stream from rtsp is ON but only by LAN not by Wifi - dont know why!

I paid for V380 9,99 GBP few weeks ago. Seller send me money back when I write to him that there is no rtsp and all stream can be played only inside V380 app on mobile or PC.

If someone like to take this “IP Camera” from me - fell free - I live near by London.

Basicly I use two ESCAM G02 and one Easy N F3 series - work perfectly fine!

Stream can be opened everywhere - on xbox and PC - under Kodi & Surveillance Room
from maikito26!

Also on mobile apps on phone and tablets.

All ports can be forwarded outside LAN without any problems.

V380 is total s**t with full respect to sellers from Ebay and all other shops.

Only one solution what I can see now is idea about…

“how change firmware V380 for any other”. I try with ESCAM G02 - none of this work so far.

Maybe you had some Idea how turn some useless piece of plastic with V380 software & firmware in to worked IP Camera ?

Hi all!
Thank you so much for your contributions. I managed to see the video through the “/live/ch00_1” url. I tried contacting support but never replied.

Ports 8899, 554 and 8800 are open but, there’s no audio!.. I’ve tried everything, any clue about how to get the audio too?

Also, port 23 is closed (@smashin firmware didn’t work) … do you know how to open it for telnet and maybe get more info?

Any help is much appreciated.

Thanks!

Try this in ceshi.ini
[CONST_PARAM]
rtsp=1
rtspaudio=1
audio=1
audiorec=1
audiorecord=1
micrec=1
mic=1
micrecord=1
telnet=1
ssh=1
onvif=1
web=1
webinterface=1
webif=1
http=1

Thank you very much Vasilii for your reply. That was a good try… but still no good luck: No audio and no telnet access. Only ports open after full scan are 554, 8800 and 8899… There must be a different set of commands for ceshi.ini maybe… ?

The support team told me there is no audio in rtsp… Did anyone manage to actually have it?
Also told me they do not provide telnet access!.. too bad.

Hello me too Ihave a V380 camera wit firmware :
appV380E12_PCARD_V50_v2.5.10.6_20190803
HwV380E12_WF3_PCARD_V50_20160217

I download th fil from smashin at Dec’18
I Unzip and paste on sdcard with FAT32
I put the SD on camera
restart camera
but the camera say it starting and connect dut no update

and what is th link for rtsp after update ?
this one ? : rtsp://user:pass@ip-address/live/ch00_0

I have a outdoor wifi cam of brand “yeshi” with two antennas (but only one is connected), none of solutions in this post solved mine issue
CPU anika ak3918
software version
V380E11_IPC38_ETH_V2.5.6.6_20181218
and hardware version:
V380E11_WF3_IPC38_ETH_V2.5.6.6_20160217

nmap show some ports open:
PORT STATE SERVICE
5040/tcp open unknown
5050/tcp open mmcc
5051/tcp open ida-agent
7050/tcp open unknown
8800/tcp open sunwebadmin
8899/tcp open ospf-lite

and tcpdump shows that 8899 is the port for video stream.
but the rtsp url in later comments does not work, i am testing on VLC

waiting email of support or more info about it

Hi, 5 monts ago I buy a V380 IP Camera:

Yesterday I try to update the firmware from the official app and this brick the device. Now the camera dos not respond, only blinks the lights when turn on.

Please, can somebody help me? Y try to find the offial support but I cant`find. The seller dos not respond when I ask for an official support.
I supose that there is a method to fix it. Please somebody help me…

the support answered me with the patch, it differ a lot from the other posted in this thread. I tried one time and just get the rtsp port opened, but i tried inserting some commands to bring up telnet and the patch does not even run again
later i will email the support team again asking for a way to open telnet. :wink:
the upgrade for my cam is just this mentioned in this forum https://ipcamtalk.com/threads/cannot-connect-chinese-360-ip-cam-through-onvif.34464/post-438089

maybe you want to try emailing the devs from this “system” v380technical(at)gmail.com

Hi,
Marvelous! Thanks for the update file. I know this is an old thread, but save my day. Btw I guest that was temporary file cause every time I restart the camera, it revert to previous state (where I can’t access the RTSP url). And also it seems bypass all authentication (username & password) so anyone with the URL can access, is there any solution for this? ODM apps can’t find any identification for my cam (chipset Hi3518E).

Being trapped at home, I thought a f fun project would be to build a home robot sentry.
The body of the robot is little more than an souped up rc car.
I have a home made app to control the body, what I want to do is put a generic v380 webcam on it and combine it with my app.
But without a published API I have to use the existing camera app, which on my Android is full screen and can’t share screen space with the robot control app.
Any ideas how to proceed?

I am in the same situation, I just got mine and the same day it was bricked… really annoyed

Reach out to the support email

Literally I was setup within a hour after sending out my email request to v380technical@gmail.com.

The more information you provide the better:

  1. Software Version of the V380
  2. Firmware Version ofthe V380
  3. Chipset of the V380 if you have it.
  4. Details of what you want to do.

They were excellent in support especially when others want to nickle and dime you. So appreciate of their staff.

I have one of these cameras (V380E2) and I managed to open the RTSP port thanks to you guys. Now the only problem left is the wifi connection dropping. If I recycle the power of camera it always connects to my wifi and stays connected for a few days. Then it looses the connection and keeps trying to reconnect every 10 seconds until I recyle it’s power again. Does anyone have a similar problem with this cam?

This thread has been wonderful! but does anyone know the root or admin credentials for telnet? I have tried root/blank and admin/blank but not working.

I have one of the V380 cameras. It did not have telnet or RTSP open, however, I was able to get RTSP with the ceshi.ini file contents mentioned above (just the rtsp=1 line). For telnet (as well as any arbitrary code) I created my own patch using https://github.com/bcaller/v380-ipcam-firmware-patch that runs a script on the sdcard when it “updates” the firmware, and then resets the sdcard files back to the preupdate state so the next time the camera powers up it will perform the “update” again, thus running the script. For my script I just have it starting telnet in the background, but I can change the script to do whatever without recreating a new patch.

To set this up, you need to get the patchv380 linux executable from the github link above. At the bottom of the readme he has a link to his blog post where he describes the update process in more detail, if you are interested. The create two files: exshell_bfu.sh and exshell_afu.sh.

exshell_bfu.sh
#!/bin/sh
cp /mnt/sdcard/local_update.conf /mnt/sdcard/local_update.bak
touch /mnt/sdcard/run.sh
chmod +x /mnt/sdcard/run.sh
/mnt/sdcard/run.sh

This runs at the start of the update and makes a copy of the local_update.conf file because the update process deletes it (in my experience). Then it makes sure a script named run.sh exists and is executable and runs it.

exshell_afu.sh
#!/bin/sh
{
sleep 30
mv /mnt/sdcard/local_update.bak /mnt/sdcard/local_update.conf
rm -f /mnt/sdcard/update_record
} &

This runs after the update completes (but before the update process changes the files) and waits for 30 seconds, then puts the local_update.conf back in place and deletes the update_record file that the camera creates to know the update happened. Basically, it puts things back the way they were so the camera will process the update again the next time it starts.

Create the patch file by running: ./patchv380 write exshell_bfu.sh exshell_afu.sh -h V380E2_C
It will output the md5 hash of the patch and create the patch file of the same name. The -h V380E2_C argument is optional but needs to be correct for your camera otherwise the update will not run. The github mentions V380E2_C and V380E2_CA, but for me I had to use V380E2_C2 for it to work. If none of those work for you, you can always open up the camera and connect a USB serial to the TX and GND probe points on the camera board and see what the camera says when booting up. It will tell you that the hwname doesn’t match and what it needs to be.

Put the patch file on your sdcard in a directory named updatepatch and create a local_update.conf file on the sdcard (not in the updatepatch directory). That contains your patch md5 hash.

local_update.conf
[PATCH]
patchmd5=12345…

Also create a run.sh script on the sd card that contains your code you want to run for the update. Anything in the run.sh script that will take a while to execute should be backgrounded, otherwise the update will never complete, the camera will never connect, the files will never be put back to start the update again, etc. For my run.sh script to get a root telnet session, I used busybox telnetd instead of just telnetd because the plain telnetd did not seem to connect properly. The below just starts telnetd on port 23 with an sh shell as root (because thats what the update runs as).

run.sh
#!/bin/sh
busybox telnetd -p 23 -l /bin/sh &

Thats about it. Like I said you can put anything in the run.sh file and you don’t need to recreate the patch to change the run.sh code.

1 Like