Fentac V380 Connection

Hey, @Yoni how did you get this camera working with Home Assistant? Could you share your configuration.yaml?

Mine is as follow:

  - platform: generic
    still_image_url: ?????
    stream_source: rtsp://192.168.0.XXX:554/live/ch00_1
    name: Camera
    username: XXXXX
    password: XXXX 

What did you put in your still_image? I managed to get the camera working with rtsp using VLC Media. But no luck getting it to work with Home Assistant.

And did you manage to get it working with ONVIF as well?


Hi, did you manage?

Is there a way to control the camera from Home Assistant also for other commands (PAN, audio, others)?

Not yet =/

Still trying

ok, I got RTSP working with ceshi.ini , but now RTSP stream is available with any password. Can you please confirm that you see this too?

Great thread!
I followed the instructions to open rtsp on a v380 Panoramic (light bulb) cam.
Did anybody manage to find a solution for start/stopping the LEDs remotely (besides using the iOS/Android apps)?
If I manage to do this this camera is a keeper.

I have the same camera with rtsp working but with the same concerns:

  • No password to access to the streaming.
  • How can I be sure the camera is not accessible from the outside or is sending anything to the outside?

I blocked the device in the router, so it should no be able, but…I want to be 100% sure

Sorry, there is nothing like 100% in this business :slight_smile:
You can install Wireshark. There you can monitor the traffic from/to the camera.
If you really are that concerned maybe you should buy a camera that you do not need to crack to get to work and that also use a password of your choice.

Hi all IP-cam maniacs :wink:

I try update V380 but I find this very difficult.

Stream from rtsp is ON but only by LAN not by Wifi - dont know why!

I paid for V380 9,99 GBP few weeks ago. Seller send me money back when I write to him that there is no rtsp and all stream can be played only inside V380 app on mobile or PC.

If someone like to take this “IP Camera” from me - fell free - I live near by London.

Basicly I use two ESCAM G02 and one Easy N F3 series - work perfectly fine!

Stream can be opened everywhere - on xbox and PC - under Kodi & Surveillance Room
from maikito26!

Also on mobile apps on phone and tablets.

All ports can be forwarded outside LAN without any problems.

V380 is total s**t with full respect to sellers from Ebay and all other shops.

Only one solution what I can see now is idea about…

“how change firmware V380 for any other”. I try with ESCAM G02 - none of this work so far.

Maybe you had some Idea how turn some useless piece of plastic with V380 software & firmware in to worked IP Camera ?

Hi all!
Thank you so much for your contributions. I managed to see the video through the “/live/ch00_1” url. I tried contacting support but never replied.

Ports 8899, 554 and 8800 are open but, there’s no audio!.. I’ve tried everything, any clue about how to get the audio too?

Also, port 23 is closed (@smashin firmware didn’t work) … do you know how to open it for telnet and maybe get more info?

Any help is much appreciated.


Try this in ceshi.ini

Thank you very much Vasilii for your reply. That was a good try… but still no good luck: No audio and no telnet access. Only ports open after full scan are 554, 8800 and 8899… There must be a different set of commands for ceshi.ini maybe… ?

The support team told me there is no audio in rtsp… Did anyone manage to actually have it?
Also told me they do not provide telnet access!.. too bad.

Hello me too Ihave a V380 camera wit firmware :

I download th fil from smashin at Dec’18
I Unzip and paste on sdcard with FAT32
I put the SD on camera
restart camera
but the camera say it starting and connect dut no update

and what is th link for rtsp after update ?
this one ? : rtsp://user:pass@ip-address/live/ch00_0

I have a outdoor wifi cam of brand “yeshi” with two antennas (but only one is connected), none of solutions in this post solved mine issue
CPU anika ak3918
software version
and hardware version:

nmap show some ports open:
5040/tcp open unknown
5050/tcp open mmcc
5051/tcp open ida-agent
7050/tcp open unknown
8800/tcp open sunwebadmin
8899/tcp open ospf-lite

and tcpdump shows that 8899 is the port for video stream.
but the rtsp url in later comments does not work, i am testing on VLC

waiting email of support or more info about it

Hi, 5 monts ago I buy a V380 IP Camera:

Yesterday I try to update the firmware from the official app and this brick the device. Now the camera dos not respond, only blinks the lights when turn on.

Please, can somebody help me? Y try to find the offial support but I cant`find. The seller dos not respond when I ask for an official support.
I supose that there is a method to fix it. Please somebody help me…

the support answered me with the patch, it differ a lot from the other posted in this thread. I tried one time and just get the rtsp port opened, but i tried inserting some commands to bring up telnet and the patch does not even run again
later i will email the support team again asking for a way to open telnet. :wink:
the upgrade for my cam is just this mentioned in this forum https://ipcamtalk.com/threads/cannot-connect-chinese-360-ip-cam-through-onvif.34464/post-438089

maybe you want to try emailing the devs from this “system” v380technical(at)gmail.com

Marvelous! Thanks for the update file. I know this is an old thread, but save my day. Btw I guest that was temporary file cause every time I restart the camera, it revert to previous state (where I can’t access the RTSP url). And also it seems bypass all authentication (username & password) so anyone with the URL can access, is there any solution for this? ODM apps can’t find any identification for my cam (chipset Hi3518E).

Being trapped at home, I thought a f fun project would be to build a home robot sentry.
The body of the robot is little more than an souped up rc car.
I have a home made app to control the body, what I want to do is put a generic v380 webcam on it and combine it with my app.
But without a published API I have to use the existing camera app, which on my Android is full screen and can’t share screen space with the robot control app.
Any ideas how to proceed?

I am in the same situation, I just got mine and the same day it was bricked… really annoyed

Reach out to the support email

Literally I was setup within a hour after sending out my email request to v380technical@gmail.com.

The more information you provide the better:

  1. Software Version of the V380
  2. Firmware Version ofthe V380
  3. Chipset of the V380 if you have it.
  4. Details of what you want to do.

They were excellent in support especially when others want to nickle and dime you. So appreciate of their staff.