Foscam FI9821W V2 - no audio / no h264

Hello - I am having a really hard time getting my settings correct for my new foscam. Ive been able to get it running using just jpeg mode, but rtsp i cant figure out and (forgive me if this is a stupid question), i dont see any options for h264 unless I do custom setup where I can select MPEG4, but cant get that working either.

Any ideas? I’ve tried almost every combination of urls in custom to get it working and I can get it running in VLC, but only because it pops up with a prompt asking for username/password. Here’s what worked in VLC: rtsp://IPADDRESS:PORT/videoMain

If this works in VLC:


Then this should work in Netcam Studio:


I can get my foscam working using this as well, but still no audio showing up in netcam studio - not sure what im doing wrong - i had to use a “custom” source and use the above address to get it going, but no matter how i do it i cant pull an audio stream.

You may have an older firmware that had RTSP no-audio issue. My Foscam FI9821W V2 has video & audio in RTSP mode (no pan/zoom), but not in JPEG mode (no audio)…

System Firmware:
Application Firmware: