HELP PLEASE! Service "Error 2: The system cannot find the file specified."

I hope someone can help me resolve this problem

I had a problem with NetCamStudio appearing to randomly freezing and ceasing to record motion activated events. (Audio events are not triggers)

I have two D-Link DSC 936L cameras and had issues connecting them to the PC’s “Hot Spot” rather than the router used to access the internet using Wi-Fi over which I have no access or control. Eventually through trial and error I succeeded BUT found that the PCs webcam was still connected so the second wireless camera was identified as license busting. Of course I removed it and then the webcam and reconnected the second wireless camera. That appeared to work but…

I’ve tried everything I can think of running the installer, repairing, uninstalling, reinstalling, repairing again but cannot find a way to correct the situation. I eventually resorted to Regedit to remove all traces of Moonware & NetCamStudio, reinstalled, then repaired but that hasn’t fixed the problem

Looking at the server log I found this entry repeating
Warning 12:12:28.684 SerializableParams.UpdateProperty Cannot Update Property StatusBarColor:-2894893. Access denied [Commercial] H 625 T 27 150.62MB
Warning 12:12:28.685 SerializableParams.UpdateProperty Cannot Update Property StatusText:$time - $pfps / $fps FPS. Access denied [Commercial] H 625 T 27 150.87MB
Warning 12:12:28.687 SerializableParams.UpdateProperty Cannot Update Property StatusBarAlpha:180. Access denied [Commercial] H 625 T 27 151.12MB
Warning 12:12:28.693 SerializableParams.UpdateProperty Cannot Update Property DisableOverlay:False. Access denied [Commercial] H 625 T 27 150.47MB
Warning 12:12:28.695 SerializableParams.UpdateProperty Cannot Update Property LogoPosition:BottomLeft. Access denied [Commercial] H 625 T 27 150.91MB

I’ve even installed NetCamStudio on another PC and copied the Programs, Programs Data & AppData over to the PC I’m having this problem with in case there was a corrupt file.

I’d appreciate any suggestions to fix or, even better, a solution.

Thanks, George

I assume that NCS X, blue icon, runs. If you google on that error you find that most likely the service name has lost the path to the executable file. If you look at the properties of the service you should have this
Most likely the path to the executable is empty or wrong. Make sure that the executable file is actually in that folder.
If this is the problem the trick is now to start all over. You can fix this in Regedit, but I would recommend to do the following first and hope that it is solved. Install NCS as usual. Install the program Revo Uninstaller or similar which is a free software that also cleans the registry when a software is removed. When asked use the Advanced mode for uninstalling. This should also remove the Service. Check the Service that it is gone. Now install NCS again, check in Properties of the service and it should be correct.
The warning above has to do with that you are running an unlicensed version.

Many thanks for the pointers… but I’m still struggling…

I found no such entry in Task Scheduler so I tried to create one and got this

I also took a look for Netcam using AutoRuns and found two entries

My next effort will be to search the Registry for scheduled tasks but in the meantime I have to run and look after my sick daughter and three grandchildren which is why I’ve been AFK this morning.

Many thanks again
Slàinte Mhath!

Of cause you are struggling since you are doing it all wrong. Why Task Scheduler? That has nothing to do with this. Read carefully my post again and it is Windiws Services that’s the probkem. Use Revo Uninstaller as I recommended.

Many thanks for your reply,

Sorry, but it appears we have a disconnect on the basis of the problem
The first image was indeed from Windows Services “Failed to Read Description. Error Code 2>”

I used Task Scheduler as test to see if I could create a task that would do the same thing which is how I found the issue with duplication

However, there is some good news… I may have solved the problem with this…
Research internally as well as out on the Internet suggest that the Transaction Log is corrupted. To fix this you need to do the following:

1. Open up an elevated CMD prompt
*2. Type in the following and hit enter: " fsutil resource setautoreset true c:* "
3. Reboot
4. After your machine reboots, you should be able to create new Scheduled Tasks now

I hope this will help others facing a similar problem :hand_with_index_finger_and_thumb_crossed:

Anyway, I can now connect to one of the two wireless cameras, the other may be powered down as I can’t ping it but, as it’s 400 miles away and my arms aren’t long enough :rofl:, I’ll ask my sister to visit my mother’s home and check it.

Strangely the Services still doesn’t appear to report that the NCS server is actually running although the NCS client can connect however I have to set it up manually with an IP address ( as it’s not discovered on the laptop’s HotSpot :thinking:
Screenshot 2022-03-18 184602

I’m going to uninstall and perform a clean install… :hand_with_index_finger_and_thumb_crossed:

Thanks for your help - sent me in the right direction.

Slàinte Mhath!