Hosafe 2MD4P-36 camera support?

I have ELP 720P rtsp and a Escam 720 rtsp IP cameras working properly in Netcam Studio and in WebcamXP, which has the great rtsp filter.

However, I cannot get my Hosafe 1080P camera working in Netcam Studio and WebcamXP. It does work in VLC by using: “rtsp://” . (Yes: 5544 and no user ID and no user PW). In VLC, the Codec information is:

Stream 0
Codec: H264 - MPEG-4 AVC (part 10) (h264)
Resolution: 1920x1090 … (yes: 1090)
Display Resolution: 1920x1080
Decoded format: Planar 4:2:0 YUV full scale.

From that information do you know whether the camera should or cannot work in webcamXP and Netcam Studio?

In VLC, CMS, and VMS, the picture is excellent day and night. But if it won’t work in webcamXP and Netcam Studio, I have no use for it.

Thank you!


Hi Frank,
Most likely it is an authentication problem. Both NCS and the WebcamXP/MUSF expects username and password. So either setup the camera for that and set Stream Type to rtsp_tcp and Address:
w/o username and password:
OBS the “:@” at the beginning.

If the Hosafe 1080P is a PTZ camera you will get video and audio with that URL, not PTZ.

I like the ELP 720P rtsp camera. Is it working fine with a good quality video and stable? What field of view /angle do you get? What rtsp do you use?


Hi Henrik,

Thank you for your time and advice.

For the ELP 720P: rtsp://
For the Escam QD520: rtsp://

Each camera has a 3.6 mm lens.

The Escam QD520 is a little more expensive, but its night range is significantly farther than the ELP.

I am trying various formats as you suggest for the Hosafe 2MD4P-36, but haven’t found one that works. The Hosafe is not a PTZ. The improvement of night range and the resolution over the Escam QD520, is very significant – well worth the additional expense. The field of view seems to be wider than the 3.6 mm but the spec states 3.6. But the resolution is much sharper even at the apparent wider angle. It has 36 IR LEDs

The Hosafe does not require a password (neither do the ELP and Escam). Should I add one just for the sake of WebcamXP? Do you have any other suggestions for URL format?

And from the VLC Codec specs, do you think the Hosafe should work with Netcam Studio and WebcamXP and the “Universal Source Filter 4.6”?

I did find two Moonware filters. Maybe one is just newer than the other. I have only tried the “16,861 KB” version:

musf-x86 webcamXP universal filter.exe 16,861 KB
musf-x86.exe 14,774 KB

Again, thanks Henrik,

Thanks for info.
Maybe I misunderstood you earlier. ELP and Escam works both in NCS and in webcamxp/musf with the rtsp above?
OK, they use a username, but not a password!

The Hosafe 2MD4P-36 http://www.lightinthebox.com/sv/2-0-mp-utomhus-with-dag-natt_p5987568.html works in VLC with rtsp:// but not in NCS and webcaxp/musf if I understand correct?

If Hosafe works in VLC it should also work in NCS and in webcamxp/musf . From the specifications this a very easy to use camera

If Hosafe need a username=admin, but not a password use
rtsp://admin:@ and stream type to rtsp_tcp.
That should work. That rtsp should also work in VLC. This is the only URL I find.

In NCS I should look like this

The only I see is that the port is correct. If still problem set also a password for the camera.

For MUSF the latest one is and you get it here


Yes. ELP and Escam work in NCS and in webcamxp/musf with the rtsp above with no password.

And yes, The Hosafe 2MD4P-36 works in VLC with rtsp:// but not in NCS nor in webcaxp/musf.

Also, in VLC, the Hosafe works if I use admin:@ and test1:test2@ . (I added test1 with pw of test2 to the camera). Although it seemed VLC was able to negotiate with the format and perhaps ignored the username and password. Just as VLC connects successfully, the URL is displayed on the screen and that URL is: rtsp:// .

I tried your example under “Custom URL” and it didn’t work. I also tried lots of combinations of username and password and was never successful.Truly odd!! The camera is stated to be ONVIF compliant, and I tried a many URL configurations in that regard but none were successful…

Do you have any more suggestions Henrik ? Thank you for your time and patience !

What the …
When you use the “correct” URL do you get a red or blue screen?
Red screen - login is not correct
Blue screen- login correct, but not correct connection string

Try this. Change to codec to Software_VLC and restart NCS

If this do not work can you give me access to the camera? Either with Teamviewer or if you port forward the camera so I can connect to it from my system.


Henrik, I get red and blue, But it seems the red screen is there most of the time.

I tried the Software_VLC setting and restarted NCS. Did not make a difference.

I’ll message you Henrick,


I’ve got the Hosafe camera working in WebcamXP with the following setup:

Network Cameras
Avtech AVN812
Video Preset: rtsp_tcp
http port 80
rtsp port 5544
camera number: 1

Username and Password: blank
No apparent suffix. I did not put the “live0.264” anywhere in the setup.

Under “Informations” is shown 1920x1080
Source Name: IP Camera [rtsp]

In VLC, the camera connects with rtsp:// . However, as soon as the VLC connection is made, webcamXP disconnects.

Does this mean only one HD stream is available at a time?

In NCS, with webcamXP and VLC shut off, “Test Connection” fails. If I exit setup, and then return to the Edit Video Source screen, a password is shown. So it seems NCS inserts a password into the stream. Perhaps that is a problem. Nothing else changes in the Edit Video Source screen.

Good, now we are getting somewhere.
There can only be ONE program running at a time displaying the camera. The camera can only send ONE stream to one receiver. If many programs are running the cam probably use the program that connected last. There are cameras that have Dual Streams, but this is often clearly marked and they are more expensive since a lot of the hardware in the camera must be duplicated.

In NCS this test connection is not relevant for rtsp streaming. It only works for jpeg and mjpeg streams due to the protocol used which it http.

The Avtech AVN812 camera use this URL rtsp:// which is quite different from what we used earlier.

So, I suggest that you in NCS use Custom URL, set stream type to rtsp_tcp and the Address:
rtsp:// since that works in VLC.

Or you can of cause use the template for Avtech also.

Can you please report back how the tests goes and your final settings since this was rather tricky to find the correct URL for the next user.


The Hosafe camera has locked up and had to be power cycled 4 times in the past two days. So I don’t trust it. So I started testing by shutting off all the camera programs. Then I tested each of the three formats you listed above. Each one failed. After each one I tested, I would quit NCS and start VLC and try the same URL in VLC to make sure the camera was still OK. The first two URLs worked fine in VLC. Of course, I couldn’t test the AVTech template in VLC.

Anyway, none of the three worked in NCS. The AVTech template works consistently well in webcamXP. But Henrik, After the AVTech template format failed in NCS, I return to the setup page to find a password inserted ("*****"). So… I am wondering whether a password is being sent to the Hosafe camera and that is why it isn’t responding. I am not real sure how to check that. Wireshark?

Thank you for the explanation regarding the streams. I have to tell you that prior to getting this Hosafe camera, I was using the ELP and the Escam as mentioned earlier. I had each run running in WebcamXP. And I also have a little vb.net program that is triggered when motion is detected or certain outside doors open here at the house. When the vb.net program is triggered, it uses a VLC plugin that displays video from those cameras; it alternates between them for 4 seconds each for 16 seconds. So those cameras do offer two streams – one to the webcamXP and one to the VLC plugin. I did have to alter the channel number from 0 to 1 ( I think it was) for that to work. Before your explanation, I assumed all of these IP cameras could serve several streams.

I arbitrarily chose the AVTech camera and the model number. Perhaps there is another template that NCS would be able to use to make the Hosafe work. I’ve tried lots of different URL combinations, but haven’t been successful getting NCS to display the Hosafe video.

I’m hoping you might know of an easy way to monitor what URL is being sent to a camera so that we can compare the difference between what NCS is sending and what VLC and WebcamXP is sending. There’s got to be a difference, right?

Thank you for the help with his Henrik

This is a mystery! All programs use the same camera file and for Avtech AVN812 it uses rtsp://IPnumber:port//live/h264

I just see an error in the URL. There are two // it should be only one. Use this in NCS Custom URL
stream type rtsp_tcp


Good catch! I didn’t notice the extra / . And when I tried the URL with VLC, that front slash was there. I just tried it again with the // and VLC doesn’t care – it just works. It even displays the URL on the video with that //. So I corrected that and tried it as Custom URL with RSTP_TCP in NCS and it does not work.

Is the error in the template datafile or is the error in the way you typed it? With the thought that the error was in the database, I just tried a bunch of other AVTech models that have the rtsp option. None worked.

I have to believe that NCS is modifying the URL to the camera in some form. Perhaps adding the : or the @ sign even though the user name and password are blank. Reminds me of what my boss used to tell me back in those terrible working days, “Son, there are no ghosts in this business.”

Do you know of a program that analyzes the data being sent to the camera Henrik? I’ll try to get Wire Shark figured out again.

If VLC and the camera accept // it is strange and I would say that the camera do not care what is after the port number
I think you tested
with no result.

NCS do not add anything be default since that would really mess up all cameras that work.

Wireshark is the program I use. When you do this in NCS what do the log file or the Event log say when try to connecting?

Another camera that use the same URL is
Digitus 16070

If possible I would really like to have access to the camera and test from my system here, because it is to much guessing now.


I’ve just started using Wireshark. It appears no additional characters are being added. I will have to learn more to be able to compare NCS to VLC

Could it be that other programs are using onvif to connect?

I found one entry that says … Not clear on how to read that.

OK, here it is:

For those of you who wonder what happened with Hosafe 2MD4P-3. After a lot of testing and analyzing of data streams Mr. frankc here changed a 0 to 1 and now it works in NCS :smile:

Correct URL is rtsp://IP-number:5544/live1.264 (This is VGA and squeezed so not really good)

Thanks frankc!