IP Camera Tp-Link C200 cant connect with Netcam Studio Server via ONVIF


i tried recently to connect my Ip Camera with Netcam Studio, but i ran into some issues.
ONVIF and RTSP are available and the services work fine with vlc media player and ispy.

I can browse the ONVIF camera and my C 200 camera is shown, and also the credentials work fine and i can see the ONVIF profiles. But when i try the “main stream JPEG 1920x1080” profile i just cant set the setting and the profile “main stream RTSP_TCP 1920x1080” seems to work, which means i can set the settings, but then Netcam just says: “connection failed.”

I have tried 64 and 32 bit versions in Windows 11 but both wont work.

Does anyone know what i can do, to connect?

Here is one image to unserstand my problem:

In the password do not use special characters like #, &, $ etc.
Copy the URL you use in VLC and paste it in the tab for Custom URL. Set stream type to rtsp_tcp or rtsp_udp.
To add credential to the URL use
There are several post of this cam in this forum. Read this TP-Link Tapo C200

thank you so much, for the solution. I did remove the special characters in my password and now rtsp_tcp works fine.