Latest Widows 10 update problems


I’ve just yesterday had the latest massive ‘we’re gonna screw your system over’ Windows 10 update forced on my computer. Lots of stuff of course stopped working including almost anything that uses Internet Explorer, but the only thing that I have not been able to get going again is my Studio X server. When I click on it now, it goes through the usual start up and Windows asks if I want to allow this app to make changes. I answer “yes” and it carries on, The little circle spins a few more times, but instead of the server start-up texts then streaming down the screen, nothing further ever happens.

Any thoughts on what this update has done and how to restore it to working please ?

Yes, we love those Windows updates :frowning: I have no idea what this can be. It can also be something else. First you can test if you can connect to the cameras. Test with a browser or if you have the URL to the camera use VLC. If that works start the installation program for Netcam Studio and select Repair. Test if that solves the problem.
If still not starting correct usually the best and easiest way is just to reinstall Netcam Studio with a clean installation.
Start installation program and select Remove. BEFORE you do that make sure you have all information how you connect to the cameras including logins!
Go to C:\ProgramData\Moonware\Netcam Studio\Server
If you have a licensed version copy the file Lic.dat to a safe place. If you have recordings you want to save keep the Library folder. Delete all the rest.
Install NCS again. Copy back the file Lic.dat.
Start NCS and hopefully it will start correct. Now add the cameras.
Good luck,

Hi Henrik. Thanks for the reply. I can confirm that I can connect to the cameras with a browser. It seems to just be the internal server that is no longer correctly starting - the little blue bird icon rather than the red client one. The client starts ok locally on the machine that Studio X is running on, but it can’t connect either so the server is definitely not running. It has been fine for months prior to this Microsoft enforced update …:neutral_face:

I was hoping to figure what had changed without having to go all through the rabbit hole of having to remove / reinstall / reconfigure the application. I am currently using a free version and I have (had !) six cameras connected. I have been developing some IP cameras based on the ESP32 cam module from Espressif and had basically got to the point where I was going to look into getting a Studio X license to remove the watermarks. Then this happened :frowning_face:

If all else fails, I will try a reinstall. Do I need to download any new version, or can I just re-run the original installation file - if I can find it. What’s it called ?

Thanks again, and I’ll let you know how it goes …

Most likely you are running NCS as a service (it will start automatically with Windows) and then try to start NCS X, blue icon. That will not work and then it will stop as you mention.

Here are the alternatives:
1 NCS X is the blue icon. This is the server plus the client together in one program. You can connect with the web client.
2.NCS Service. Start NCS as a service. Now you can run the windows client, red icon. You can also run the web client.


OK. So based on what you just said, some progress being made. I pulled up the Task Manager and had a look in ‘Services’.

“Netcam Studio service 64” was showing as stopped. So I right clicked to to “Start” and the status changed to “Starting” and then “Running”. My phone pinged, and I then knew that it would be working - and indeed it was. So now I’m a bit confused. I don’t believe that it has ever been an automatically starting service at Windows boot time. I have always had to start it with the blue icon, and it always has started like that no problem, indicating, from what you say, that it indeed was not automatically started. So I feel that the Windows update has actually done something to stop the server start utility - blue icon - from working. Add to that that the service was never started automatically, and that takes us to where we are (were) right now with the server not running.

So I guess that the easiest way to resolve this for now is to make sure that the service is listed to start automatically at Windows start up. I’ll have to look at how to do that - unless it’s a couple of keystrokes that you happen to know off the top of your head ??

Good. For me it seems that everything is working correct. How to set NCS Service to start with Windows read this guide Using Netcam Studio Service

OK, thank you. I’ve set it to ‘Automatic (Delayed Start)’ - correct ? One last question. On the Netcam Studio app on the iPhone, whenever the server starts, it sends a notification and the app responds by putting up a number on top of the icon to count the notifications. What is the proper way to clear those ? I’ve done it on a few occasions, but never really worked out how. After I’ve been into the app and done something, it’s “Oh, they’ve gone !” :thinking:

Finally (finally !) what sort of subscription do I need to run six or up to say ten IP cameras on a home installation ?

Thanks for all your help. Greatly appreciated

Purchase of license and more information is found at