Library is empty after server restart

Library is empty after server restart, but all recordings are still in the “Path to local library”. Is this by design? Also not sure if its related but “Free HDD” is always reported as “0Mb”

running on 2008R2 x64, and library path moved to “D:\ProgramData\Netcam Studio\Data”

Hi kevink! Just curious which processor do run this on? I run 2008R2 under VMWare E3 Proliant quad core and dedicated only one virtual processor to do this. It usually use 80-90% of performance. I might have to re-install an dedicate at least 2 virtual processors? Thats why my question ;).

Xeon X3440 quad core on local machine no VM. Netcam Studio uses 6-9% cpu with only 2 ip cameras.

Thanks for info! I use 8 cams, but I think I need to add more virtual processors to make it run smother. Otherwise, I like this software a lot.

No it’s not by design and shouldn’t happen.

The library index is saved when the software exists (and every 3 minutes in case of software or computer crash). So even if for whatever reason the computer would crash you should in worse case miss the last 3 minutes in the library.

What settings do you have for retention (both retention period and maximum allowed space).

Does it do the cleanup properly when the files have expired (or the alloted space is exceeded) ?

The 0mb occurs on some systems but shouldn’t be related. I’ll try to reproduce.

Thanks for your response. Retention was set to 30Days and 200GiB.

For testing I just change it to 1Day but was not sure if sever needed restart after make this change, files were not being deleted. After server restart files were still not deleted and Library was empty again.

When the software starts or is quit, do you have similar errors in the event logs as reported here:

Yes I think so:

(Error @ 08:04:22.975 - H:829 - M:330.32MB) SaveSettings Error in MoonwareServer.SaveSettings
Exception Detail:Unable to generate a temporary class (result=1).
error CS0012: The type ‘Moonware.Common.ItemEntry’ is defined in an assembly that is not referenced. You must add a reference to assembly ‘Moonware.Common, Version=, Culture=neutral, PublicKeyToken=null’.
error CS1502: The best overloaded method match for ‘Moonware.Core.ItemQueue.Add(Moonware.Common.ItemEntry)’ has some invalid arguments
error CS1503: Argument 1: cannot convert from ‘object’ to ‘Moonware.Common.ItemEntry’

Yes, it seems to fails in saving the library index file.

Actually there is another user experiencing the same but we still couldn’t reproduce here or find the root cause.

Do you have .NET 4.5 installed ? All our test systems have 4.5 however NCS only requires 4.0.

Yes I have only .NET 4.0 installed.

I can install .NET 4.5 if you think it may help?

Please try, i’ve asked the other developer to also investigate on this issue.

If we have no choice we will modify the way we save the library index because the problem seems to come from here (XmlSerializer) but it would be nice to understand the root cause.

Apparently, it seems confirmed to be specific when .NET 4.0 is installed but not 4.5

Please install .NET 4.5 until we solve the problem so that it works with .NET 4.0 as well.

.NET 4.5

That was it, works great now, thanks…

When deleting/removing from the library the video gets deleted from folder fine but the thumbnail stays in the folder is that normal?