Microsoft.Net Assembly registration Utility will not work when i try to install webcam XP 5 free i get that message!

I try to install Webcam XP 5 free. But I recived continue the massage that Microsoft.Net Assembly registration Utility don’t work.
I try to fix it with net frame work repair tool.
But there is no good result!
I am new to webcamXP5 free.
Will there be someone to help me out!

I don´t know what Windows version you are running, but control that you have .NET Framework 3.5 SP 1 running.
In the Manual on page 5 there are some prerequisites that you might check out.
I did a search on this and it seems to be a bug in .net framework 1.1 which is rather old.

If you are testing software I would recommend you to look at Netcam Studio instead. It is from the same company, but much more modern. You can use the complete program for 2 cameras for free. Especially, if you plan to use cameras with very high resolution Netcam Studio handles that well. Find it here


With the latest RTSP Filter, it’s now .NET 4.5 which is required.

Maybe an update of the prerequisites on the web site would be a good idea.

Yes it sounds like an idea however it’s normally automatically detected during installation and should install it if needed.

However since this won’t work on Windows XP i have to modify the installer to make installation of the RTSP filter optional so that it’s still possible to install webcamXP (without RTSP support) on windows xp.

Hi Henrik,

My system is windows 7 32 Bit incl. sp1 with 4 GB ram.
Processor is Intel Core 2 CPU 6400 @ 2.13GHz 213GHz.
and I have installed .net framework 4.5.2

I follow your advise and try netcam studio. that will work o.k.
but it take a long time for me to understand the program.
the main reason is the language I am not that good with English.

Thanks so far.

Well, it cannot be that bad. Your written English is excellent!
Your computer should not have any problems with this, but try Netcam Studio.
If you need any assistance, please contact us again!

Hi again!

I just installed this software on my win10 32 bit machine and I got the same error!
I am running Netcam Studio on the same machine with no problems. However, we must investigate what this is.


You have this message during installation not while starting the software ?

Can you please post here a screenshot of the error msg. Ideally with the console / logs from the installer if they are visible at the time of the error.

Did you install Visual C++ 2013 redistributables for x86?

Well, of cause I did not. But, now when I have it works fine! :slight_smile: .Windows, windows …

Henrik and others,

I do install Visual C++ 2013 and before that I install also KB3083710-X86.msu and KB3102810-X86.msu.
The reason is that I do not get a update from Microsoft.
Now all is working O.K.

Thanks for all your co-operation
This problem is solved and the topic can be closed for me.

Excellent! Thanks for your feedback!