Mjpeg -> Vera Plus

Hello. I installed Netcam Studio because i wanted to include a camera to my home automation system Vera Plus. http://getvera.com/controllers/veraplus/

Vera only supports jpeg and Mjpeg streams to include camera, and my camera only has h.264. Netcam Studio should give a Mjpeg stream on url: 19x.xxx.xx.xx:8100/Mjpeg/0 right?

When i try to test 19x.xxx.xx.xx:8100/Live/0 i can open that stream in VLC, but when i try 19x.xxx.xx.xx:8100/Mjpeg/0 in vlc nothing happens. Is there a bug Mjpeg ?

Hi Fleksnes!
I just tested in version 1368 and it works. However, you need a token also in the URL string. Go to Settings and Generate HTML and you will get the correct URL. Make sure the selected user have permission to view the source.

Hi Henrik, thank you for your answer. Im on the same version. I tried, but still no luck :frowning: from the log:
Exception Detail:Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host.
Any ideas?

Hi again!
I was wrong there. I just copied the generated URL into a browser and it worked. For VLC it is a no. I checked the manual and as you say for Live it works, but for Mjpeg it is a no. I used a NCS 1.3.1 also with same result. I am probably missing something here. I have to consult @Steve our developer here.

I’m not sure VLC accepts this kind of mjpeg streams because it’s not properly wrapped into a container (avi, mkv or mp4).

It’s using a kind of oldschool browser trick to send one jpeg image after another, not pretty standard for media players and this is why not even all browsers are supporting this approach, it is exclusively intended for streaming to browsers.