My 4th IP Camera not Working! Thanks for the help, anyone!



Hi, I have a trouble shooting question regarding Netcam Studio 32bit free version. I have three cameras conntected, 2 via USB and 1 via IP address. The 3 cameras show fine, but I have been trying to add a 4th IP camera but can not do it. For the settings of the 3rd IP camera which works, I have used HTTP Port: 80 and RTSP: 555 and IP address and Source#4 with ID and password correctly entered and it works and displays the camera’s view fine with the “Unlicensed Source” message on top. But for the 4th IP camera which Netcam detects with the correct IP address of, I tried for hours different numbers for the HTTP Port of 79, 90, 99, etc, and the RTSP of 554, 556, 599, but not luck. It doesn’t work. May I ask if the reason is because the free version limits the number of views to 3 cameras? or maybe I am missing something. I am able to access my 4th camera, a DLink 930L via a web browser and view it there fine. Thank you for any help.


As far as I know, the free version doesn’t limit the number of cameras you can add, it just puts that red banner over them, so that shouldn’t be the issue.

When you connect to the camera with your browser, do you just type in and that works? If so, you should just need to be using the default ports of 80 and 554.


Hi, thank you for the reply. Yes, I just type in in a browser. But 80 554 still does not work in Netcam.


As far as I know, the url that ends in “top.htm” is only for viewing the camera through a web browser.

Can you try adding the camera using the “Custom URL” option with the following:

stream type: MJPEG
URL: http://admin:admin@

You’ll have to replace the admin:admin part with your specific username:password for that camera


I tried that and entered my username and password for the admin:admin part but it returned a The connection has timed out error message.


Well, we know your camera works, so it’s just a matter of getting the right URL set up in NCS to get it working.

Once Henrik is available, he’s really good at remoting into your computer using things like Teamviewer to help you get things set up.

I wish you luck :slight_smile:


Wait, I just noticed you said first, then Any chance it’s because the 107 IP was correct and the 104 IP wasn’t?


107 is for my other IP camera that is working correctly with Netcam. 104 is the IP cam I can’t get to work. Yes, I might need some remote assistance with this one. Thanks for the help.


Hi guys!
D-link is quite good to tell what URL to use for connecting to the camera. However, for the 930L it is a little bit more diffuse. The D-link 930L only delivers a jpeg and mjpeg stream so for the best quality we use the mjpeg stream over http.
Here are a couple of alternatives for you.

  • Connect using a template in tthe tab Network camera. Fill it out like this. Add your username and password. Make sure it is the correct IP. Test connection.

  • If that do not work you need to use Custom URL.

For Address test these ones:




Please, report back how it goes and which of the URLs that work.



It works! The 1st option you suggested which I tried of 80 554 but with the jpeg for video preset didn’t work, but when I changed it to MJPEG as you suggested, it now works! Thank you Henrik! You’re swell. I will now feel good about purchasing the paid version knowing all 4 cameras are working fine. Thank you, have a good one.