NCS server at an IPv6 WAN address?

Is it possible to connect to an NCS server at an IPv6 WAN address?
If yes, how do we connect to the designated port, e.g. 8100?
I can probably configure a IPv4 VPN workaround, but would prefer something uncomplicated.
(Sorry if this rather basic question is a well-known issue; Googling it yields no results, apart from one inconclusive conversation in this forum in 2015 …)

Interesting question. I searched and read this " Port restrictions for IPv6 are identical to those available in IPv4 . TCP and UDP have separate port spaces, each identified by port numbers in the range 1-65535. For IPv6, ports work the same as IPv4 ."

To add a port number to an IPv6 address write for example http://[IPv6 WAN address to router]:8100/
If the router is setup correctly it should forward port 8100 to the NCS-computer on the IPv4 LAN address.
I assume that cameras are on the IPv4 LAN. If a camera is on another network where you need to use the IPv6 address in NCS I have no idea how that will work. Maybe you can setup a DDNS service where the IPv6 address is translated to the traditional “

Please report back how it goes.


Thank you, Henrik.
My question spoke of a server at an IPv6 address. As you know, the concept of “LAN” is different with IPv6, because there is no NAT. Every device has it’s own unique global, WAN-accessible IP address. The router doesn’t forward or translate to local LAN addresses and ports; it simply passively and transparently passes data onward to the target device. So yes, all devices connected to the router constitute a physical network, but they are also independent & autonomous.

Quick test from a TCP client (Firefox):
Works: (WAN)
Other addresses in the 192 dot 168 and 10 dot 8 (VPN) ranges also work
Fails: http://[2604:6000:1501:xxxx:xxxx:xxxx:xxxx:xxxx]:8100/#/login

All of these addresses are readily PINGable from the client, and all refer to the same device. I have not yet tried it from the full NCS client (v1.9.2), for fear of disrupting a working IPv4 configuration (P.S.: I have never understood how to change the WAN address of a particular configuration, without erasing it and starting from scratch!).

Sorry but you wrote IPv6 WAN address which for me is the public IPv6 address to the router.
So 2604:6000:1501:xxxx:xxxx:xxxx:xxxx:xxxx is the IPv6 address for the NCS-computer.
Test also with another browser than Firefox since there is or were a bug in Firefox for IPv6 addresses.
Hm, maybe have to investigate this :slight_smile:
If you solve this I would be interested to know how :slight_smile:

Well, I can’t get IPv6 to work locally. From my computer I can ping a NAS, but I cannot connect to it. Something fundamental is missing. Anyone have a magic wand :slight_smile:
NCS webserver listen only to IPv4 port 8100. I assume it must be configured to also listen to IPv6 port 8100.

Yes, Henrik. I’ve tried a dozen ways to get this to work, without success. And my DD-WRT router (Netgear R7000P / AC2300) can’t run NAT64, so that workaround is unavailable. IPv6-only networks are proliferating (one is coming to me, against my wishes, in about 3 months), so I hope to be prepared …

Hello Henrik,

I had to change my environment to IPv6 and therefore I had to deal with it a bit more intensively the last days. Inevitably, I had to deal with my Netcamstudio installation.

Unfortunately I did not get beyond the local access.IPv6 as such works, the IIS webserver configured on port 4711 is reachable. The NCS on port 8100 unfortunately not.

Do I think too simple, if I assume the “error” with a NCS web server not prepared for IPv6 access?


Hi Udo,
can you run a

netstat -a

on the NCS Server

Hi Matthias,

sure I can :wink: what do you expect to see?


If the server is listen to via IPv6

unfortunately no, at least no IPv6 with port 8100, where the NCS server is reachable under IPv4

Hendrik do you have to change ipv6 in the software?
that the server is starting with ipv4 and ipv6?

Well, this is tricky. NCS use ports 8100, 8120 and 8124. Port 8120 and 8124 listen to ipv6, but not 8100 which is the web server. So this needs more investigation.

1 Like