NCS Service issue since Windows update

My NCS Server (Windows 10 pro) has been happily running without a reboot for around 3 weeks now. Went to check everything and there was pending updates and it wanted a reboot. I rebooted, updates installed and it carried on as normal. Until I tried to connect to it from my phone. Couldn’t find the PC at all. Tried another PC, still couldn’t find the server. So I restarted the NCS service. No difference. Turned off my antivirus. No difference. Restarted the machine. No difference. No device could connect to the server either with the app or web client or windows client. I then loaded the client on the server and it worked! But still no other devices would work. Then… I stopped the service and fired up NCSX. Everything back to normal!! Connected from other device last as normal. Great I thought. Close NCSX and restart the service. No good. Back to NCSX. All good again! All this since the windows update. I done a full clean install of NCS and the issue is the same. @Henrik can you help at all? Next step is new windows install but don’t want to go down that route. Ports and firewall are all open. I’m on 1.9.2 and all IP address have been checked. Thanks.

This might be the issue. If you have a password set to enter the computer it turns out that the NCS service might need to login to an admin account. Usually it is possible to run NCS service on a local account apart from when there are network activities like storage on a NAS, but now it seems that login to an account with admin rights might be necessary.
Another user had this issue for some time ago, but I don’t see that on any of my installations yet. This must be a change in how Windows services works or a setting or a …
I am running computers on Windows Insider Program to keep track of changes beforehand, but this I have not see so far.

I’m on an admin account. And the service logs in with an admin account. I am puzzled! But for now I am running NCSX so all is good. I’m going do install NCS on a spare computer I have when I have time and see how it goes. On the spare computer I will do all windows updates etc and test from there. It looks to be a firewall issue though as I can connect to the service from the client on the same machine without issue. I will do as many tests as possible and report back :+1:

Do you have this in Firewall settings?
Can it be that the LAN changed from Private to Public or vice versa?
Just disable the Firewall and see if that works.

I have tried setting all to public and all to private. Even disabled the firewall and my antivirus (avast). All made no difference. I can connect to the computer to browse files etc, and ping the IP address too. I’m so puzzled but I will not be defeated :blush:

1 Like

Is the service running on port 8100?

Yes. Tried changing ports too. Did another clean install of NCS. Still the same. Going to try on another computer over the weekend… :slight_smile:

Finally fixed it @Henrik :slight_smile: I did all the suggestions again - disabled firewall, disabled anti-virus, clean install of NCS, nothing worked. So I took the step to reset Windows 10 back to factory default. I then re-installed NCS and copied my license file back. Set up my cameras and all is good now. I can access NCS from any device (on or off my LAN) again. So not sure if the Windows update actually broke something, or if it was a coincidence, but I installed all updates before installing NCS. This wasn’t an inconvenience though as the server is only used for NCS, nothing else runs on it. Happy ending :slight_smile: :slight_smile:

Excellent! Never give up.
Unfortunately, sometimes Windows updates play tricks on NCS. Sometimes it’s easily solved and sometimes it takes a little bit longer.
Happy it all works again!

1 Like

Always great support here! Keep up the good work :blush:

1 Like