Netcam Server fails to start/Counter Name issue

Hi there - on a clean Windows 11 PC, was able to install and add license for Netcam Studio. A week later, the Server doesn’t seem to start, and when I run the client I get an error message that says:

Login failed: Cannot load Counter Name data because an invalid index ‘’ was read from the registry.

Error in the event log says:

Application: NetcamStudioX.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.InvalidOperationException at System.Diagnostics.PerformanceCounterLib.GetStringTable(Boolean) at System.Diagnostics.PerformanceCounterLib.get_NameTable() at ystem.Diagnostics.PerformanceCounterLib.get_CategoryTable() at System.Diagnostics.PerformanceCounterLib.CounterExists(System.String, System.String, Boolean ByRef) at System.Diagnostics.PerformanceCounterLib.CounterExists(System.String, System.String, System.String) at System.Diagnostics.PerformanceCounter.InitializeImpl() at System.Diagnostics.PerformanceCounter…ctor(System.String, System.String, System.String, Boolean) at System.Diagnostics.PerformanceCounter…ctor(System.String, System.String, System.String) at Moonware.Common.ProcessorUsage…ctor() at Moonware.Controller.ClientController…ctor(DevExpress.XtraEditors.PanelControl, Moonware.Common.NetConfig) at Moonware.Netcam.XtraConsole…ctor()…

I’ve tried the “clean re-install” instructions (though not sure where c:\programdata was intended to be) and no dice. I realize this is similar to this thread: NCSX crashes on fresh install - #19 by Henrik but that thread had no actionable resolution… any further thoughts on this one?

Well, of course I think I figured it out after I posted.

Per random internet advice for the exception - your mileage may vary - I ran “lodctr /R” twice from an admin command line and that moved Netcam Studio past the error. Then Netcam Studio had a null reference exception, but I found the programdata\moonware folder by accessing it from an admin command line and renaming the moonware folder to something different. It now boots up so I think I am out of the woods.

In principal Netcam Studio is not officially approved for Win 11 yet. However, so far it works well.
What happened is most likely a Windows update of net framework that did not go well. It quite often works if the update is uninstalled, NCS runs again and then use Windows Update again.
Here is how to make a clean installation if necessary .How to make a clean installation of Netcam Studio

I too experienced the
“Cannot load Counter Name data because an invalid index ‘’ was read from the registry.”
error after my Win10 computer BSODed for reasons unrelated to NCS, but while NCS was running. A fresh install of v195 did not fix the problem, but mammeria’s “lodctr /R” solution, above, worked immediately, without further problems (no programdata\moonware folder issue)! Many thanks for that. Note that it only worked after opening a CMD.EXE session from Explorer with “Run as Administrator”. If lodctr generates an error, you are not running as Admin. Lodctr should generate this message:
“Info: Successfully rebuilt performance counter setting from system backup store”

See also: