Netcam service not starting

Have set Netcam Studio Service to automatic in services
But the service is not starting up. Its just listed as automatic, but not running.
If I then start it from services all starts and all works fine

Running Netcam Studio version on Windows 10 Version 1511 (OS Build 10586.17)

Any ideas?

I got this problem too. Also with same OS and software, curius for solution.

This seems to be a problems for several applications with windows 10 like Microsoft SQL Server and others which service do not start automatically. A solution that works for some is to reinstall the application again under win 10, but that do not work for everyone. In the prerequisites for NCS Win 10 is not listed, but I hope they have it working soon.

And I’m having the same problem. Whenever my Windows 10 server reboots, the netcam service fails to start, even though it’s set to automatic. If I try to start it manually, it always works.

Tried reinstalling and made no difference.
Tried on another couple of PCs with Windows 10 and it does the same.So must be a bug somewhere, as it worked in win 7 and 8.
Was thinking perhaps if it could be done with some sort of bat file to do the net start to run on the pc reboot.

I tried this on windows 7 pc too, but I got this problem i win 7 too. Any advice? after my pc reboots when installing updated 04:00 this service is stoped

Microsoft have changed how services works in Windows 10 and therefore have old applications using the service problem to start even though the service is configures to start automatic. Many software vendors have problems with this now and updating their software. However, the service can be started manually with and continue to work. Go into the application Services (search for that) and scroll to find NetCam studio in the list. Click on that and then click on start in the menu to the left. This should work. If you reboot the computer do this procedure again. Windows 7 should not be a problem though.

I have the same Problem on Windows 8. Any solution?

Odd after a reboot last night it seems the service started fine.
So just rebooted again and its starting the service fine now.
Did not change anything from before.

Magic of computers ;). Was it a reboot due to a system update?

Thinking that it may have been the last cumulative update for Windows 10 on Dec 8th that made it work.
It took it to Version 1511 (10586.29)
Quite a few reboots since then and its all working fine.

Just tried on a win10 pc with an ealier build (using a backup) and its not working, so that update may have helped.
Will wait for it to update and lets see…

1 Like

Excellent information! Thanks a lot. This will help many people.

Another solution that seems to work is to change the service from automatic start to delayed automatic start.

Just an update on this, does seem it was the w10 build that fixed it, as that backup build got the update I mentioned above and also is working fine now. To really test, re did the older build backup and same so it was W10 causing the problem wth the service, but all fixed now.
So glad, as will be monitoring the cameras over Christmas more than usual when out and about and no need now to remote login to start the server service.

Thanks! Happy Holidays!