Netcam software issues and RTSP connection issues with Wansview 720p K2


I’m trying to connect to 3 of my RTSP ip cameras.
iSPY and VLC media player can open the connections using ( rtsp://admin:123456@ ) but nothing that I try in netcamStudio will open the stream :frowning:
I’m under custom url using RTSP:TCP / RTSP:UDP
The camera is a wansview 720p K2

I have 2 D-link DCS-5222LB ip cameras and they work with no issues on RTSP ;o

Any help would be appreciated :slight_smile:



Hi Shawn,
If it works in VLC it should work in NCS. However, … :slight_smile:
Test the following:
-In the specification of the camera ( it says it support ONVIF. When add the camera to NCS use the tab ONVIF source and use the IP number you have.
-add the camera using the tab Custom URL. Most likely the stream type is rtsp_tcp.
URL rtsp://admin:123456@
I have added the port 554 if it needs that. Make sure logins are correct. Test also to change ch0 to ch1



I do know now before the hole issue with NCS now that I got them working using
Wansview : NCM625M _ RTSP (port 80) so weird…

I will test the custom url soon I’m currently facing a new issue.

I sent a message to NCS tech support about it.

I have gotten the 16 camera license and activated the NCS with it. I was running the free version and all my sources were working at the time, after activation nothing is working now. I have rebooted windows that has not fixed it. All of my cameras are connection failed.
So I removed all of the sources and started to re-add them all when I get the the TEST Connection bit I click on it and it shows connection successful Green dots. (also checked with VLC RTSP ports and they are working ) So I click the Check Mark to add the source and then it still is showing connection failed over and over.

I have rebooted all of the cameras and tested each with RTSP with VLC media player and they are working.




Never mind I fixed the issue!
I deleted everything inside of " C:\ProgramData\Moonware\Netcam Studio\Server " before doing so I made a backup of the “Lic.DAT” file. After deleting the folder I restarted windows then reopened NCS Server waited for a bit then closed it and ended the task in task manager. I reopened the " C:\ProgramData\Moonware\Netcam Studio\Server " folder and pasted back the Lic.DAT file and restarted the NCS Server again this time the Key icon in the top row went away meaning that the software was activated again. I then added my fist then second then … 5th camera and everything is working !

@Henrik: I tested the custom url for RTSP_TCP and that didn’t work but it did work in VLC ;/ . But it does work using Wansview : NCM625M _ RTSP (port 80)… I guess that is the same thing.

Error connecting to camera RTSP_TCP // working using VLC and iSpy software

Certainly strange. Just entering a license number should really not do this. The red image usually indicate no connection to the camera. When using RTSP the Test result should not indicate anything since the cmara do not respond to such a test so the green icons are not correct. If you change to MJPEG what happens. Testing for MJPEG works since the camera respond to that. Still green icons?
What do the Event Logs say? Is it red icons there are no connection to the camera. Still VLC is working though.
Since no camera is working I would do a clean installation. Use the installation program and Remove. The go to ProgramData-Moonware and delete all with Netcam Studio. Then go to ProgramFiles and Delete folder Netcam Studio. Now install NCS again. Add some cameras and check and the add the license and then continue to add cameras.



Please review my latest post I got the software working again doing what you actually suggested before it was suggested :slight_smile:

Before fixing the software it would just spit and error saying failed to connect to "
rtsp://admin:123456@ " Putting that same error url into VLC played the camera every time…

Here is a screen capture of the RSTP /MJPG D-Link camera test



Fine, problem solved!
Many cameras have the same electronics, but with different brand. There are many more camera manufacturers than there are manufacturers of electronics :slight_smile:
The test for MJPEG is correct since MJPEG do not support audio. The test for RTSP is correct since RTSP support video and audio, but I have to check. Our briljant software developers might have changed something :slight_smile:
Thanks for info,


I wish the issue was over, today at work I noticed that my cameras weren’t working. I got home logged on to the dedicated Windows 10 PC and had a look. NCS server had stopped working… okay fine just close and reopen like any other software, but nope now all of my video sources are offline re-connecting again like last night.
I can pull up the cameras on a separate app on my phone they are all working correctly. I did however notice that the one source "netcam studio smart camera “Android phone” is still connected and working… Any ideas ?

2x D-Link DCS 5222LB1 (rtsp)
3x wansviwe K2 (rtsp)


So I went under " C:\ProgramData\Moonware\Netcam Studio\Server " deleted all of the files again and that fixed the issue. This is such a pain :frowning:

So I have now diverted and installed NCS on a vm running windows server 2012R2 on my ESXI 6.5 server. The license let me activate the key on that box without needing to deactivate the old one? New thing or is that normal? I will post an update on how the vm handles the cameras vs the dedicated windows 10.

Windows 10 Pro x64
CPU i5-2400
RAM: 4GB ddr3
SSD: junky 90mb/s R / 90MB/s W
1GB/s Hard line to WiFi router
1GB/s Hard line to storage server ( ESXI VM )
1GB/s Hard like to internet

ESXI 6.5 server specs for vm
OS: Windows server 2012 R2 x64
CPU: E3-1230 V3
RAM - 32GB DDR3 (Dedicated to vm 4GB)
SSD: RAID 0 4x 250GB samsung evo 850 (vm datastore vmdk storage location)
1GB/s Hard line to WiFi router
1GB/s Hard like to internet

10GB/s internal network to storage location.
HDD: RAID Z2 26TB ( video storage location )

Full server specifications:


Day 2 update everything is still working correctly at this point on the server 2012 R2 install.
Could it be that the software didn’t activate correctly on the windows 10 install and it was just crashing the software or the camera sources ?

  • Shawn


Hi Shawn!
Activation should not do that then all of us should have that problem. Activation only remove the red banner and allow some extrav stuff. Since it works fine on the ESXi and a VM it must have been something interfering with NCS. A good place to look at when strange things happen is the Event Viewer and Applications. When NCS stopped you most likely had a red error icon for NCS and information about what closed it down.
But for the moment we are happy then :slight_smile:. In one of my system with 22 cams I run the same server specs with server2008r2 and it runs and runs … for 4 years now with no problems at all! Depending on your geographical location a UPS might be good.


Already have plenty of ups units installed :slight_smile:
Day 3 everything is working except I’m seeing some weird frame drops on the cameras during a motion detect record.

All of my cameras are doing it. Of the 5 cameras I have 2 same type cameras D-Link DCS 5222LB1. One of the D-Link cameras is set as wifi connection and the other is on a Ethernet cable. Both cameras are doing the same frame drop during recording events. I will post a video from each in a bit. Since you said that you had 22 cameras on the same hardware spec did you see anything like this happening ?


Hi Shawn,

On my VM with server2008R2 the CPU load is always 95 to 100% so it is overloaded, but it works very fine. I have very few frame drops, but it is no problem for me. Due to the high CPU load the FPS from the cameras vary from 5 to 20, but it not limiting. I record in 10 FPS. All my cameras are on cable. For about 4 years ago I said no no to wifi and everything is on a Gbit backbone. I am very happy with that decision. All my cameras/servers/NAS´s/router/switches/… are on a separate energy system powered by an UPS. All this have saved me a lot of time and the reliability and uptime is extremely high. Yes, it has been some additional costs in this, but I need to have a system that I can trust.

Your system with these 5 cameras should really be no problem for the i5 or Xeon processor if you are running NCS with default parameters.
-what is the CPU load of the VM?
-what FPS do the cameras deliver? See bottom right corner on the video.
-what FPS do you save recorded videos in?
-since you have the licensed version you can test to enable Multi Threading in Settings - Decoding/Encoding. Running a VM do not support everything, but you can test. I do not use these in my system.
-the orange icon in the Event logs indicating Connection lost is typical when for example wifi drops out or if the energy to a camera goes down for a longer time or for a glitch on the voltage.

From the postings in this topic there are too many problems. So maybe it is a good idea to go through the whole chain from camera-network-switches-router-computer that it works correct. The frame dropping is typical when something is overloaded or the data traffic do not get to the codec in time.



Shawn - Thanks for posting this issue. I just recently had the same issue, and clearing out the ProgramData…\Server folder did the trick. I assume something became corrupted at some point and the refresh populated the files needed to capture the video.

Henrik - I reviewed the log data from NCS and I dont see anything that would indicate how this would happen.