Netcam Studio 1.5.2 client won't start

Netcam Studio 1.5.2 tested on Server 2008 r2 and Windows 10.

Client tested ok on Windows server 2008 r2.

Client tested on Windows 10 but fails to open\start and produces event error (sent via email to support)

1.5.2 fixes email notifications with pictures attached and server appears to be streaming better than previous versions.

We are temporarily using 1.5.1 client on Windows 10 and ignoring warning message about version differences, those who want to use 1.5.1 client connecting to 1.5.2 should not attempt setting changes via the client, settings should me made on the server running 1.5.2 client as a workaround.

Notification emails are behaving a little strange compared to earlier versions. On Android emails are displayed as expected with photos loading correctly. On Windows 10 mobile (Outlook) placeholders are displayed and the email is in a state of permanent loading… touch one of the picture placeholders and the image is displayed and email loading completes. Unsure why this is happening but it is not an issue with other emails with either embedded or attached images.


Also finding it weird considering that windows 10 is probably the most used operating system for Netcam Studio and currently nobody else seems to have this problem. I’ve quickly tried as well version 32-bit on my Win 10 test system (because I usually focus on the 64-bit version) and didn’t see troubles but what is somehow even more surprising is the type of crash.

Netcam Studio Client just like Netcam Studio X is equipped with a technology that normally catches crashes and send crash reports, this really helps us to locate the problems and understand them however here it’s somehow outside of the app that it seems to crash and therefore wasn’t triggered and couldn’t be catched.

Can you please just try to run the client as administrator and see if that helps ? I have my little idea on what it could be but it would be strange that nobody else had it (starting by Henrik and myself).

And netcam studio x working ok on this windows 10 machine ?

Because netcam studio X is actually netcam studio service + netcam studio client in the same app so it this one works it pretty much limit the areas of where the problem could come from since the only difference is how the images are sent from service to client (through shared memory when using service + client which is actually the part that I’m suspecting)

Agreed that this is strange, however It is not unusual that we find issues before others.

Yes, Previously did try Administrator start up with same results.

Tried upgrade of existing 1.5.1, when startup failed, we uninstalled 1.5.1 then installed 1.5.2 with same results.

Windows 10 1703 build 15063.250

So you confirm that 1.5.1 client is ok but 1.5.2 is not no matter which version runs as server ?

Working configuration is

Server and client 1.5.2 on Windows Server 2008 R2 working as expected.

Client 1.5.2 on Windows 10 installs but will not start (both 0x86 and 0x64)

Windows 10 is 0x64

Installed 1.5.1 on Windows 10 and it connects and performs correctly when connecting to 1.5.2 server. (except of course settings)

I have not reinstalled 1.5.1 server on Windows 2008 R2 since upgrading.


Windows 10 1703 build 15063.250

That is the new Creators update? I have not tested on that one yet.


Yes, 80% of our customers are now on creators update. So we are testing and getting ready for a demo of netcam studio.

Work around is fine for demo purposes. But this customer is also on creators update.

I’m also running 1607 (Anniversary Updated) on my 2 Win10 system.

Will look forward upgrading one of them.

What about X because on this one i suspect that if the client doesn’t work Netcam Studio X 1.5.2 also won’t work right ?

I have only tested client on Windows 10 creators update.
I will test full install on another Windows 10 Creators update later tonight.

Installed Windows 10 1703 build 15063.250 and here are the votes:

I am running NCS as of yesterday.

-NCS X runs with no problem.
-Win client connect to NCS X with no problems.
-NCS Service runs with no problems.
-Win client to NCS Service runs with no problems.


Same here, also upgraded one system to same Windows 10 PRO build and Service, X and Client running properly.

OK - Have moved to a different machine - Windows Server 2016 1607 14393.1066

Did a custom install of NetCam Studio 1.5.2 0x64 - all except server components - failed to start client

Did a full install of NetCam Studio 1.5.2 0x64 - Client worked and connected to other server running on network with 1.5.2

Appears to be some component in the customer installer that is dependent for both server and client that may no be installed when selecting client, tools and library only??

Ahh, now that you say everything :slight_smile:

Well at least we know where to look at but yes some of the dependencies (probably devexpress) are marked as server side dependencies and also used by the client and most likely were not installed…

Yes, that I can confirm:
Installing only client, tools and library will not start the win client.

1 Like

I’m pleased that we found the probable cause :slight_smile:

1 Like

So it was purely at installer level, i’ve rebuildt the installation packages after movin the new dependencies under libraries (not server).

Now it seems ok, please confirm that this package is ok:

and mark the topic as resolved if it’s the case.


Yes, it works here.
But now I have to write more than 20 characters which I have done now :smile:

Tested 0x64 version - Client, Tools and Library - all ok

Thanks :slight_smile: