Netcam Studio Central

I see a lot of references to Netcam Studio Central in the forums. Where do I sign up for this service, since that appears to be the only way to get push notifications, such as those from motion detection, to work? Thanks!

Hi Jordan!
I saw your post in the other thread so I tested to sign up for this myself with no luck. I seems that the account server is not responding. I have forwarded this so I hope it is solved ASAP. I will be back when it is up an running again.

Hi Jordan,
Follow the instruction here Enable Push Notifications and SMS notifications in Netcam Studio
When you get an email back to Activate the account click on the link. Most likely the link is https://xxxxx change that to http://xxxx Now you can continue.
If necessary go back to NCS and click on the icon for Netcam Studio Central and login. Now it should work. I just did this process myself with success. For the moment there is a problem in this that we are investigating.

Error: The username is not provided. Specify username in ClientCredentials.

I have done this process myself with no problems. Therefore, I need more detailed information what you do and when you get this error message.

I edited the file, as instructed in that thread. I open NCS X. I click on the plug button. The popup occurs asking me to login. I click on “register” and enter my information. The previously mentioned error pops up.

I just registered and got this

This should not be a problem, but maybe you use special characters in the password like %, #, …? Try to use upper/lower case a to z and numbers and see if that works better.

Password is not the issue, as I tried not using numbers/letters on the last one and it specified I had to use them. So, now I am using a combination of numbers and letters with no combination. The error message seems to suggest that there’s a problem with the code? “ClientCredentials” is code language, yes?

ClientCredentials is the Registration information. Username is most likely the email address since that is used when logging into the service. If you leave the field email address empty will it complain about that?
Nevertheless, something is going wrong and it seems to be local. So I suggest that the next will be that you first uninstall NCS and then install it again. This is a classical approach, but hopefully it will solve the problem.

Does it matter that I have the server service running and I am having to open up the NCS X server application when the service is running?

Also, with e-mail left out it says “Email is required!”

Having NCS Service and NCS X running at the same time should not be possible. Stop the service and make sure that only NCS X is running.

OK, I started the Service and then started NCS X. However, it stops when I starts to load services which are used by the Service. Starting the Push process ends up with this :wink:

So close the Service and it will run as planned.

I stopped service, tried, failed with another error, which I’ll get to. Uninstalled, reinstalled, tried again and got the same error.

Error: Access is denied.

I am not sure how to continue this. I think the best way to assists you is if I can get access to the computer that runs NCS using Teamviewer. If that is OK I send you a PM for exchange of details.

I guess that’s fine. It also acts weird in server mode. I originally was simply running the sever service on startup and connecting/modifying the system through the client. Now, with the service not started and running NCS X, it doesn’t really allow me to add cameras or see users, etc. Very odd in the server mode.