NetCam Studio Client not displaying videos


I have 4 Reo-Link cameras connected to the latest version of NetCam studio. I set everyting up using the server aplication, then switched over to Service. I can’t get client on local machine (or remote machine) to show any images under Views, I get a CameraDownload error:

Infromation form Server in CameraDownloader:WorkerThread@04.03.2016 14:15:51.826
Mapped Memory for Preview(1) is not available, Web Server will be used.1
Exception Detail:Access to the path is denied.

Interestingly, the Sources drop down shows all cameras, and the remote IOS app works just fine.

Any ideas?


Hi Macky! I have the same situation as you describe. I get this error message, but I have the live video. I assume you get the error message in the Event logs. I have 2-3 questions to clarify:
0. when you switch over to NCS Service you exit/stop NCS X and start the NCS Service in the Services menu.

  1. When you under View select the matrix 2x2 (or 3x3, …) for the 4 cams do you see a live video from the 4 cams or do you get 4 grayish images or 4 black screens?
  2. In the Event logs and in the column Critically there are icons with different colors. Is the color of the icon red, green, or …


Henrik, Good to know someone else has the same problem.

Do you also have Reolink cameras?

  1. Correct, I exit the NCS-X and start the service. I haven’t checked the events log at that point.
  2. on the windows client, I see the NCS Logo with an error message for all 4 cameras. One of my cameras used to work but then switched to same logo-error screen.
  3. In the events log and coumnt Critically I get lots of error messages with Red icons with the error I described before.

Not using Reolink cameras, but they seems nice.
I forgot, everything works fine in the web client and in iOS app?
In the web client you can also check the logs. Looks fine there or?
That error screen is usually when login is not correct.
Can you make a cam available for me to connect to?
If you can, please give me the URL which helps a lot ;).

Yoy can also test it in VLC. If it works in VLC the chance is very high for good result in NCS.
Check this link
Important might he to set h.264 to Baseline.

Everything works well in the IOS app. By web client do you mean the Netcam Studio Client app? if so, that is where I am having problems.

I haven’t tested VLC in the last few days, but I’ve never had problems with it.

If you send me a private note I can provide access to the system.


Aha, then I understand. Do this:

  • Add camera using Custome URL
  • Set Stream Type to rtsp_tcp
    use this URL

With web client I mean when you connect using a browser to http://ip-to-ncs-server:8100

I had the same setup (custom URL) but running MPEG4. Switched to rtsp_tcp, restarted the service, restarted the client GUI, no difference.

Tried the web client, works just fine and is responsive. iOS on IPAD still works fine.

Also, I am back to one of the 4 cameras working.

Then I would check the configuration of each cam to look the same as the working cam.

Done that too. All configs are cut and paste in NetCam studio, and the settings are identical in the reo-link gui. I think I’ll do a factory default on one of the cameras and set it up again. will let you know how it goes.

Or, since everything works fine in NCS X (server) something might have happened in the installation. Start the installation program and remove the application. The camera profiles will be saved. Install the system again and run it.

If you have ncs x running and connect using the windows client. Is that OK?

Henrik, Stopped service, rebooted, uninstalled, rebooted, reinstalled, rebooted. No difference.

Stopped service, rebooted, started gui server, all cameras work.

Started NetCam Studio Client on another computer, I am not able to view the cameras on this client. So this isn’t service related. Could it be a firewall issue? this is a new install of Windows 10.

Henrik, I am unable to post to your private thread as i am a new user.

Problem “solved”. Many cams today have a lot of megapixel in resolution. It seems that the resolution in NCS to work in all clients is limited to 1080p. We have to look into that.

Hi Macky! I hope everything is fine with NCS and the cams.
I encountered exactly the same problem in two more cases which one is my own when adding cams with many megapixel. Our programmers just discovered the source of the problem and it is now corrected. The change will be from the next release.