Netcam Studio Crashing / swscale-3.dll?


I’m having a problem with NCS craashing a lot. After about 10 mins it will crash with a “C++ runtiime error” dialog but this is the info from the event viewer:
Faulting application name: NetcamStudioX.exe, version:, time stamp: 0x57230f9e
Faulting module name: swscale-3.dll, version:, time stamp: 0x37513749
Exception code: 0x40000015
Fault offset: 0x0003949c
Faulting process id: 0x1168c
Faulting application start time: 0x01d1b15b36a8e06e
Faulting application path: C:\Program Files (x86)\Netcam Studio\NetcamStudioX.exe
Faulting module path: C:\Program Files (x86)\Netcam Studio\swscale-3.dll
Report Id: 0409b7c0-8a9d-471a-80ac-cae76b4a9ca3
Faulting package full name:
Faulting package-relative application ID:

This is on windows 10.
Both the 64bit and 32bit have the same crash issue. I’ve reinstalled twice.
I have one IP cam - Cisco WV80 and a rtsp cam set up (using the Zoneway profile but its a generic rebadged similar model).
I’ve verified I have full .net installs etc and the latest C++ runtime libraries.

So far, I think the application is great, but I just can’t keep it running long enough to fully evaluate it.

Any tips appreciated.


Hi John! I hate when these things happens also :wink: You are the first one with this error. Thanks for the info above, but we need to find out a little bit more.

  • does it happen when you dry-run, i.e. with no cams connected?
  • is it with a specific cam?
  • does it happen when you start motion detection or is it when the cams are connected and doing nothing?
  • if you have some more info it is valuable.

I direct this also to our developers @Steve to have a look at this.


Hi Henrik,

thanks for the quick response. I’ll run through some of those tests. However, when it was happening, I had the rtsp camera in a single view. I’ll check to see if that was the only case.

Ok, I did a few tests.

  • Dry run : I removed the cameras and the dry run did not appear to crash.
  • It seem to happen with either camera when I run it with just one.
  • motion detection was not enabled on either camera when it was crashing
  • I added the cameras back in using the custom urls (instead of a device profile) that worked in VLC before I tried NCS. It took a bit longer to crash, but it still did.
  • I’ll try to set it up on another machine and see if it still happens

Side note: When editing the camera settings - it’s not clear what tab data is being used. If i initially added a camera via the “Network Camera” tab but then chose to use a “Custom URL” (vis “Edit Video Source”), both tabs have the data/profile and it’s not clear which one is active/being used.

OK, thanks! Is this high resolution cams, like 1080p or higher? Try another machine is good.
Concerning using which tab. For me it is one or the other and not a mixture. I have not seen the programming of this, but I would be very surprised if it mixes the tabs. The Custom URL tab is really the raw thing to communicate with the cam.
Looking forward to your next tests.

I didn’t intend to mix tabs, but wanted to ‘edit’ the camera rather than removing and adding again but that may be necessary. Maybe add a ‘use this profile’’ checkbox or something?

This is a 720p DbPower VA038k - a rebadged chinese ptz dome.

I can provide the onvif profile from the Onvif device manager. Is that something that would help you? (Like add the camera to an official profile?). It’s detected in the ODM but not your app.

Yes, that info would be great so I can add it to a template.
There was a buffer problem with really high megapixel cams that is solved in the update, but 720p is today nada ;).
Another machine or you have of cause already done the good old windows trick to reinstall the software ;).

Hi Henrik,

How do I PM you? I could only screen cap the ODM profile (can’t imagine why it wouldn’t let me copy the text) and didn’t really want to subject the community to the images. Thanks.

You should have a PM in your mailbox. Do NOT reply to the mail. Use the link to the forum. -Henrik

Just an update for anyone with a similar issue. It seems to be a bit more stable if I run as administrator. I’m guessing Win10 might do something with the permissions on some of the underlying system files… (this is the x64 version)

So, if you have issues or weird behavior, try running as admin.

Thanks again to Henrik for the help… if I learn any more, I’ll update.

Thanks for update with good news! Yes, Win10 have caused some problems before so in general installing as admin and running as admin is recommended. At least in more complex programs. NCS use a lot of hard core system resources.

I am config a template for the cam and I have not quote got the connection url to the cam from the onvif you sent me. Can you give me the rtsp://… If you use that or in the onvif manager click on imaging settings and on top should have like

I am very interested in what´s to left of the red arrow ;).


Hi Herik,

I didn’t install as admin but that’s a good suggestion. After running as x64 as admin, I’ve been up for about 2 days now. I used to get anywhere from 10min to an hour.

As far as the URL… xxx:554/11 it’s one of the cams that does the 11 at the end. It seems there there are a few that use 11.

Thanks alot, now I am happy :). The onvif cams seems to merge to 1 or 11 which they shouöd to comply with onvif. The cam have a substream also and I assume that eill be 12 then. Now it’s only the PTZ, puh !
Are you sure it is the DbPower VA038k? That is an 640x480 pixel rather old cam and not ONVIF… Can you please check again.
Running for 2 days. Thar’s an eternity in IT ;).
Thanks again!

I’m pretty sure it’s the VA038k, I think they updated it to 720 but didn’t change the model number. But… i could have been suckered. I can’t find the 720p reference now. Hmm… however, it’s very likely a rebrand of some other OEM for Foscam or Wansview. (It loosk identical to the Foscam FI8919W - but the foscam site says that only mjpeg… but it’s more likely the wansview NCM626GB…arrgh, I guess I should have bought a real branded camera)

However, NCS just crashed. I might have figured out the issue. I don’t think it was the “run as admin”. When I accessed the camera from another machine (using another program), NCS crashe a few mins later. So, I wonder if there is a conflict of some sort with two programs accessing the camera. I’ve had VLC and other instances access the camera at the same time before - but not with NCS. So, wondering if some

Just another data point.

Well Mr. John what are you doing ;).

If the cam can deliver 2 streams there is absolutely no problem. Accessing the same cam with two different programs is of cause nothing to recommend, but if that should make NCS crash seems strange. I am doing that constantly for test purposes and nothing crashes. Did you install NCS on another machine? Can you reproduce this crash? Can you get from the log what is crashing? It seems that you have other things going on in your IP surrounding that might affect NCS, but …


i confirm what Henrik suggest, give it a try from another computer, can be a laptop or whatever that can also access those cameras.

This is just to exclude the fact it may be due to a faulty memory or unstable system. Did you use those cameras successfully on the same computer using any other / competitor software ?

What is the memory usage of the software and are you running the 64-bit version ? The 32-bit version may crash if its memory usage gets above 1.2GB of ram.

HI Steve and Henrik,

I did have a chance to put it on another computer (2 actually). One more Win 10 machine, and a Win 7 machine. The Win7 is a ‘utility’ machine that doesn’t have much on it. I’ve been getting the exact same error on all the machines. Win 7 was 32bit, both Win 10 are 64bit. Both 32 and x64 versions crash the same way. My latest test is running the the 32bit/Win10 in Win 7 compatibility mode as admin. Oh, and I have tried both cameras with other programs without issue. I wouldn’t expect it’s due to the cameras since they are using pretty standard steams. As noted above, accessing via VLC via urls works just fine (and a few other programs). Looking in the event log, there are a few “device lost” messages. A new theory is that maybe that is happening too often and something in NCS says “'enough”. I’d admit that one cam is on a bridged network connection farther away and the connection is a bit slow/hiccupy - so at times a lot of millisecond drops may occur.

Otherwise, I must commend you on a great product. Great feature set without being overblown. Clean design. Perfect for diy basic security system.

Thanks again!

Hi John!
This is getting really interesting! For the moment I am residing in Brasil and have connected cams to my NCS from US, Europe and Vietnam with no problems … It is very strange that NCS crashes in the same way on all your test machines. But, you never know. You might have discovered something. Therefore, it would be most valuable if you could give us access to one of the cams. Maybe, the one on distance. I will add it to my system here and see what happens. I send you a PM that you can respond to with IP etc if you have the time to assist us in this.

When it crashes, does it offer to send a crash report ?

Hi Steve,

It only opted to send a crash report once. I did ‘accept’ that hoping it might get back to you and provide more details. Each time it crashes, the event log still blames swscale3.dll, but the dialog at crash references the C++ library. Hmm…