Netcam Studio Service not working properly

I am using Netcam Studio Service to monitor a webcam. When I connect using the Client, I can properly see the webcam, but i can’t configure it (for instance, i can’t enable-disable motion detection). As soon as I press Apply the following error appears:

System.ServiceModel.Security.SecurityAccessDeniedException: Access is denied.

Using Netcam Studio X everything works fine, but I don’t want to stop the service every time I want to change the configuration or use it as the Service automatically starts when the computer powers on.

I’ve tried to run the service as an administration account and give the client administration privileges, but nothing worked. What can I do?

The operating system is Windows 10 Pro 64-bit.

Thank you.

Hi Eloi!
“What can I do” I hear your desperation so I will try to solve this mystery ;). When it comes to webcams they can have some issues sometimes. Hm, this is a tricky one since everything works fine in NCS X. Here are some ideas that you can test in any order.

  • it is a security message and a message about connection to the cam so it can be two problems.
  • when you start NCS X are there any errors in the log that rolls up?
  • it is a security message with access denied. Some antivirus programs can cause problems sometimes. Make sure to disable that or completely remove it and test. Maybe also uninstall/install again.
  • something went wrong in the installation process of NCS. Completely remove NCS including the files in ProgramData-Moonware-Server. Install again.
  • webcams can cause problems since some only work well with NCS 32-bit. Since the webcam works with NCS X this is not likely, but install NCS 32-bit and check.

That´s my suggestions for the moment. Test and please report back how it goes.

Hello Henrik.

Thank you very much for your time and ideas. Finally, what worked, was to install the 32-bit version, so problem solved!

1 Like