NetCam Studio Stopped Working After Update

I’ve been checking a solution to this problem for a couple days now. I’ve uninstalled and reinstalled it a few times, deleted Moonware/Netcam’s folders in Program Files and ProgramData and still no success.

Everything was working fine until I updated NCS to 1.6.1. Now starting the server I get “Netcam Studio failed to start: Operation is not supported on this platform.” I’m running Windows 10 1703 Build 15063.483.

The log window shows a few steps in orange and just one in red. and I just realised I can’t use the scroll wheel on the log window, and if I scroll up it goes back down… ah! details! Anyway, the red one says

[the time it happened] - ConsoleHost.StartServer (H:874 - M:92.90MB)
Exception occured in StartServer
Exception Detail: Operation is not supported on this platform.

Hi Amanda,
That sounds a little dramatic. I am running exact that version of Windows with no problems so we need to find the source for this on your computer. First it seems form your description that you have made a clean installation where you have deleted all files. My question about that is if you first run the installation program and selected remove all and then deleted what was left? If you just deleted on the hard disk it can still be information somewhere in Registry or …

A couple of times it have been a problem with antivirus software.
Can you uninstall 161 completely and then install an older version of NCS?

For the moment that is what I have.

Yes this message is really strange.

Do you have a 32-bit or 64-bit version of windows ? What about the version of Netcam Studio (32-bit or 64-bit) ?

By just googling this error, it seems in some cases to be related to certificates and SSL?

Did you try to setup SSL in Netcam Studio ? If so try to go back to the default HTTP mode.

Btw, what’s your platform? What type of computer and CPU are you using ?

Finally please report the version of .NET that is installed but anyway normally it’s 4.6 coming with Windows 10.

Apparently when it occurs when starting a WCF server (what NCS does on startup), it could also be due to one of the port being already used (in this case it’s probably the port 8192).

Please ensure that no older instance of NCS or any other application uses this port.

I created the thread just before I was about to go away on a months long trip. I was hoping to have this working so I could check on my home while I was away. I didn’t get it to work. I got back and now I’m back trying to get this to work. Just explaining the four month gap.

@Henrik: The reason why I deleted the folders was because I had read somewhere that it could help for this particular error. It must’ve been on this forum. I can’t remember. I remember uninstalling and installing NCSX quite a few times. Trying both 32 and 64 bit versions to no success.

@Steve: Windows is 64bit and I was trying to install the 64bit version of NCSX before trying the 32bit version. I did not try to use SSL with it because I access the camera via VPN. Didn’t think it was necessary. On this same machine (which is a test server that doubles as home media server) I also have Apache, MySQL, Mezzmo, a Torrent client and Edge - only. As far as I know port 8192 is not being used. The version of .NET I’m using is 4.6 the one that shows in NSX’s pre-requisites download page. Hardware wise this is an AMD Athlon 5350 with 8GB RAM. I have two webcams connected (an HP pointing to my living room and one those cheap off-ebay ones pointing at my office) I also have plugged in a USB DVB-T receiver. I remember during the attempts I removed all USB devices before installing. Oh, and all drives, including C: are Bitlocker encrypted.

I just tried installing again and got the same error. I hope you guys have another suggestion because re-installing Windows on this machine would be a huge problem due to some extremely unstable Apache plug-ins I rely on that would be very difficult to get them to work again.

Thanks for the help anyways.

Hi Amanda,
-which version of NCS worked? Do you have that one and can install it again?
-make sure that port 8100, 8120, 8124 and 8192 are not used by other applications since you have a lot of them.Use Resource Monitor and Listening ports.
-make sure that no instance of NCS is still running. Use Task Manager och tab Processes fo control. If you find any just kill them.


the previous version that worked was I uninstalled 1.6.1, re-installed 1.3.7 and for some reason quite a few errors came up. some in orange and a few in red.

I also before installing the older version checked the ports and none of the ones you mentioned are being used.

I took a screenshot of the log window, hope it helps.


To be sure, you completely removed all NCS folders in ProgramData?
If you did that and 1372 is now not working I am not sure whatelse to do. Installing as admin? Problems with encrypted disk? Do you have another computer?
Sorry, out of ideas.