Netcam will no longer start

Error is:
Configuration System Failed to Initialize

I tried rebooting, uninstalling, reinstalling, same error!!

Anything i should try next?


Unable to send error report:

Hi Graham,
We are checking why not the error system could not receive this information.

So the problem is when you try to restart NCS. NCS must then have been stopped. So why was NCS stopped? Usually, when this happens it is when
-the computer crashed and then rebooted
-upgrade/update of a software program or Windows operating system.

When this error occur it is usually:
-the configuration file or system file of NCS is corrupted,
-the new update/upgrade is in conflict with NCS.

What to do?
-do a clean installation of NCS. Remove ALL NCS files. Using the installation program and select Remove do not remove all files. After using the installation program and Remove go to C:\ProgramData\Moonware and delete the folder Netcam Studio. Go to C:\Program Files\Netcam Studio - 64-bit and delete all in that folder. Install NCS again.
-if the above do not help something else is blocking NCS to start. It can be a new installation of an antivirus program. It can be an update of Windows OS: Start the Event Viewer and look into Windows Logs. Check in Applications and System. There is information about why a program crashes.


I have done a clean installation of Netcam as outlined above. Twice. No help.

The system had memory added to it. I went from 8GB to 24GB. That is the only change, yes, it rebooted and netcam was stopped to do that. It did run after the upgrade, but it seemed to have reverted to a demo install. I then needed to restart the system for another reason and netcam would not run, and has not run since. The other function of this system is to run multiple VM’s from VirtualBox - that is working fine.

I do not see anything in the vent viewer that appears to pertain to this issue, but there is a lot if information there, is there something specific i should be looking for?

This is a system on an internal network, the firewall is not running and no A/V software is installed.

It would seem that you would know why your software throws this error message. I see another thread with the same issue and the solution was to re-install windows - that is not an option for me.


Re-installing Windows seems a little drastic. I don’t know if that was actually done.
0.The license is based on the hardware in the computer so when you added more RAM that parameter changed and therefore the license you have from the beginning is not valid any more. When NCS is up and running again you just need to do the licensing process again and it will work. In the meantime the full NCS software will run for the two free cameras and a red banner over any additional camera.
1.NCS was running with no problems also with the VirtualBox running and 8GB of RAM?
2.Then you changed from 8 to 24GB of RAM and now NCS is not running?
3.What is the operating system?
4. Check that ports 8100, 8120 and 8124 are not used by any other software. You can use Resource Monitor.

Try to start NCS and when it crashes go to the Event Viewer - Windows Logs - Application. There you should have a red Error icon in the left column and Netcam Studio in Source.

Also, check in Task Manager and in the tab Processes that there are no processes for Netcam Studio running. If there are kill them.

If nothing helps is it possible to go back to the 8GB of RAM just to be sure since that was the only change.


OK - I gave up and blew another windows 10 license on a VM for netcam. Seems to be working. I tried everything above and could never get it to run again on that system… So now I am setting it up…again…

Thanks for your help

1 Like

I had this same problem after installing an older version that was linked from my license registration email. It prompted me to upgrade to the latest version, which I did, but then would not start again. The last steps from this page fixed the issue! Here they are:

  1. Head to C: \ Users \ username \ AppData \ Local \ appname on your Windows 10.
    Delete the app config file.

  2. Head to C: \ Users \ username \ AppData \ Roaming \ appname on your Windows 10.
    Delete the app config file.

  3. Restart your app and check if the error still occurs.

1 Like