New PC with Windows 10, not able to view cam from internet


#1

Hi there,

I always had Webcam 7 working on my HP Evo sytem. It streams images from my local birdhouse to a website on the internet. The PC had Windows 7 on it.
Sadly the Evo has passed away :wink: And now I upgraded is to a fresh system. It’s got Windows 10 Home on it.
I gave the new PC the same IP adress as the old one. So port forwarding doesn’t need changing. My USB camera works fine when i view it locally (192.168.2.4:51) I enabled the webserver with my external ISP adress. Just like it always worked on te old PC.
So the only change is a new pc and windows 10.

Can any of you techboys help me out what I’m missing here? I disabled the firewall in Windows 10, but still no wan images. So I guess it’s not firewall related.
I also deleted the port forwarding rule in my router and recreated it. Even tried different port setting, but still no go.

Please help me, I’ve got a lot of followers who want to see our great tit nesting :slight_smile:


#2

Hi,
Port 8080 should be forward in the router to the computer running Webcam7. Make sure that port 8080 also comes with. Set a static IP on the computer.
This “I enabled the webserver with my external ISP adress”. That is not correct. That should be the IP of the computer running Webcam7.
-Henrik


#3

Hi Henrik,

I tried with the settings you mentioned. But did not work as well.
I did revive the old PC, fired up webcam7 and it worked like always. Port 8080 is linked to my NAS. Port 51 goes to webcam7. Port 51 is open in router and points to the pc running webcam7 (as it always has). So from the internet http://84.82.179.***:51 brings me to the webcam7 view, which is what I want :slight_smile:
When I connect the new PC, with all the same settings in webcam7 as the old pc, I get a time out on internet url.


#4

Something is blocking.
-default listening port for webcam is 8080. Changed to 51?
-check that Windows firewall port 51 is open.
-antivirus prgram blocking port 51? When installing webcam it opens port 8080, but 51 needs to open manually.
-change port to 51, Save settings, then restart Webcam7.


#5

Ah! That was the problem!! I didn’t know you had to open a port in the Windows 10 firewall as well. Just opened port 51 in de Windows firewall and poof! everything works like a charm :smiley:

Thank you so much for brainstorming with me :+1: