New updated iOS and android app lost settings and not working

The new Netcam studio app that went out and installed from the stores yesterday is not working well.

For my iPad2 ios lost the settings, so redid server and all ok.

On a Samsung Galaxy mega 6.3 had this problem, lost settings, can add server, hit connect, thinks about it with a please wait small popup and then returns to add server page, with no error, but not connected.
But I noticed the server was adding a blank space at the end every time.
This device is working now.

On a Samsung Galaxy tab running Android getting a box up that just says;
Application error
The connection to the server was unsuccesful (file:///android_asset/www/index.html)
Ok box
After selecting ok it takes you back to home screen
Have cleared cache and uninstalled and reinstalled app, and still the same.

Well settings not kept was not possible avoid here. It’s not really an update but rather a new app written on a new framework etc…

Then yes suggestive keyboard seems to add spaces sometime on android also not sure what we can do here but maybe filtering them before saving sound like an idea.

And finally for the galaxy tablet no idea unfortunately…

Ok thanks for quick response.
It adds the keyboard extra space on all my android kit, tried about fifteen differing phones and tablets.
Never seen that before on Android.

Having the same problem with my Google Pixel as I mentioned above with the the Samsung Galaxy.

On Android, it sometimes seems to be connected with the app, but each source says not connected.
Look via Netcam studio client on PC and all is fine.
Kill android app and launch again on the Android device and all is fine. Seems an intermittent bug.

On iOS using the iPad pro 12.6 inch, selecting Library>List> and selecting … crashes the app
Happens everytime.
Have seen this a few times also with iPad2.

Also, on iOS, once I have been in the library section and then click on the hamburger menu to go back, I get the list like sources through to About, but they do nothing apart from take me back to the libray section I was already in.

what iOS version ?

Don’t have any of these problems on iPhone 7 and on iPad Mini 4.

I have 16 sources, do you have more than this ?

As for the extra spaces they will be filtered in 4.0.2

The iPad 2 is on version 9.3.5.
The iPad pro is on 10.3.1

Server has only two sources at the moment.

By the way that hamburger menu bug only happens once you have been in Library>List
It is fine when starting Library>Mosaic and Library>Hourly
and starting from all the other sections.
It looks like it is stuck in ta loop once Library>List is chosen.

I use library list all the time and it didn’t happen to me a single time.

I have another instance with 2 sources, will give it a try as well but strange…

I’m also having issues with the new app on Android. I am using for dynamic DNS and it worked perfectly on the old app. New app only works with IP address. Dynamic DNS works fine on any browser, even browser on phone, so I know it’s not my setup. Nothing changed except the new app. Any Ideas?

I use no-ip dns and its working fine here.
Have you checked its not adding a blank at the end of the dns address?

yep. I’ve deleted and recreated it a few times. So weird. IP works perfectly. I’m stumped. Copy and paste into mobile browser and it works fine.