No audio on live stream and recording issues

Hi guys, i’m having some issues with the latest version.
Since the upgrade i did last night, i don’t have audio stream.

The server is up, recording with motion sensor. In the server machine the live audio in the client is ok. But the recordings doesn’t have any sound. And the netcam clients on remote machines either.

The streaming signal on web browsers (Chrome and I.E.) is also without sound.

I tried, reinstalling, different client machines, changing streaming format (Vorbis, AAC, Mp3, etc.). None of this seems to work.

Before the upgrade it was working flawlessly so i would love you to help me.

Thanks in advance.

Sound seems to be working as usual. Do you use the exact same template you were using before ?

On one of my camera, sometime after 10-20 days the camera stops providing audio to netcam studio or to any other software and i have to power off / power on. Maybe just reboot the camera to ensure that the problem is not at this level.

Hi, thanks for answering.

Yeah, I used the same template. The only change was the update. During the day I reinstalled the camera drivers and switched it from USB port. A few hours ago I removed the server (x64) and tried with the 32 bit version but the issue is still there.

As I said before, the audio is ok on the server machine, I can hear the audio stream on that PC, but on the other clients no.

I was looking on the Event Viewer and found some logs that may be helpful

I have several entries like this:

03/05/2015 05:25:45	Source(0)	An error occured while executing Action MotionFinished on Camera 0 - Microsoft® LifeCam VX-2000. Exception Detail:No se puede generar una clase temporal (result=1). error CS0012: El tipo 'Moonware.Common.ItemEntry' está definido en un ensamblado al que no se hace referencia. Debe agregar una referencia al ensamblado 'Moonware.Common, Version=, Culture=neutral, PublicKeyToken=null'. error CS1502: La mejor coincidencia de método sobrecargado para 'Moonware.Core.ItemQueue.Add(Moonware.Common.ItemEntry)' tiene algunos argumentos no válidos error CS1503: Argumento 1: no se puede convertir de 'object' a 'Moonware.Common.ItemEntry'

And this:

IOException in StreamEncoder.MP3.GetStreamFeed() Exception Detail:No se pueden leer los datos de la conexión de transporte: Se ha anulado una conexión establecida por el software en su equipo host.

Thanks for your help.

Have the clients been updated to 1.1.5 as well ?

Yep, all clients are 1.1.5. But the problem also occurs when I use the browser.

I have just removed the 32 bit version server, then run ccleaner and then installed the 64 bit server. Still the same. The audio only works on the server machine.

Any idea?

after uninstalling, verify that no file is left behind in c:\program files\Netcam Studio

Maybe a wrong version of a dll was not uninstalled.

Nobody else reported the problem so far and it couldn’t be reproduced on our end.

I did what you said and the problem is still there.
Can I just install the previous version?

Previous versions stopped working on May 1st so no you cannot.

Ok, I get it.
i’m on my own.
I wonder how you tried to reproduce the issue without even knowing what operating system I’m using. Or without viewing the logs.
Do I have a firewall? Am I trying to make it work inside a LAN or through WAN? Is there any router on the network?


The error is clear, one dll refuses to load on your system. Usually either another file is present in the folder and conflicts with it or another dependency is missing on the system. No further logs are required and for sure firewall is not involved. The only thing I cannot explain is how it used to work previously since nothing changed regarding dependencies…