No Audio w/ Foscam 9831W - Microsoft Creators Update cause problems

After Foscam stopped supporting their web plugins I’ve been looking for a new way to view my cameras and have so far liked NetCam Studio.

The camera I’m using (9831W) comes with both a microphone and a speaker (two-way communication) however in the setup for the camera source the “Audio Preset” box is greyed out and I can’t get any audio from the camera. We use this camera as a baby monitor, so having audio (at least from the camera) is a must. Is there any way to fix this?

Foscams are always a little bit tricky to get to work and older models sometimes have problems with video and audio in the same stream. NCS only support listening to audio. Make sure that the latest firmware is installed in the camera. However, to get video and audio we need to use rtsp stream. Test this. Set RTSP Port to 80 or 88.

If you go into the configuration of the camera you should be able to see which port the cam use for rtsp.

Do PTZ work?


Awesome! That worked. The whole RTSP thing was confusing me because of the “(Port 80)” in the dropdown but then the default “Port 5xx” in the manual entry field. Glad that sorted it though. :slight_smile:

As for the PTZ, yes it works. However it’s very aggressive and if I mess up the position I have to use another mobile app (which has much finer controls) to get it back into position. Do you know if there’s a way to alter how much it moves when pressed? Perhaps in a config file?

Thank you!

Excellent! Thanks for reporting back. I will add port 88 in the template. For PTZ I also have to check what is set as default in the template and adjust that.

Hi Henrik,

I’ve updated to the latest Netcam Studio ( x64) and unfortunately audio is no longer working again. Unlike last time I can enable/disable audio via the overlay button but no audio is being transmitted. I’ve checked via Foscam’s own app and there is definitely an audio signal being received and transmitted by the camera itself.

The settings are as before which enabled audio the first time (Port 88 as above using RTSP).

On the other hand, PTZ controls are much more refined! Thank you! I no longer have to jump back to Foscam’s app just to move the camera.

Hi again,
Well, you cant have it all :wink: From version 137 to 143 the saving of the camera information have been changed which might cause this. Test this:

  • in ncs right click on the camera video and go to edit video source and save again.
  • If you only have one camera delete/disconnect it from NCS.
  • add the camera using the custom URL.
  • set Stream type to rtsp_tcp.
  • Address is rtsp://username:password@ipaddress:88/videomain

Test if you will have audio with these. Difference is the resolution. No PTZ, but as a test.

If that works go back and add again as a template to also get the ptz.


Hi Henrik,

I deleted the camera and reconnected as a network camera (the usual process). No audio.

I then deleted the camera source again and added via custom URL and it won’t connect at all, with either the videomain or videosub. I only get a red “Connection failed” screen.

Tried Stream type rtsp_http as well, just for good measure, but that also didn’t work.

If for some reason it is case sensitive use videoMain or videoSub
Also, of cause the good old trick, restart the camera ;).
If this do not work can you give me access to the camera?

Okay, it was case-sensitive so that worked to see the video but still no audio.

I could arrange for you to see the camera at another time, but not at the moment as we use it as a baby monitor and the little one is sleeping. :wink:

We’re GMT +1 here.

Well, the little one have of cause priority. There is plenty of time to learn about IP cams and Netcam Studio :slight_smile: Usually, I am also at that time zone, but for the moment I am at GMT -3 and no day light saving which makes it 5h here in Northern Brasil.

Do this cam support ONVIF? I searched and there are different versions and I am not sure which one is yours. If the cam support ONVIF clear the template and clear the Custom URL. Then add the camera using the ONVIF tab. Version 143 of NCS have now support also for ONVIF PTZ.

We have about 200+ version 1.4.3 out and it is very quiet actually, but it is always a first.
One last thing if you have the time, uninstall NCS completely and install it again if something went wrong in that process. Start the installation program and click on remove. The important parts to remove is also the settings which you find in C:\ProgramData\Moonware\Netcam Studio\Server Delete all in there. Install NCS again.
I send you a PM for exchange details.

Hi Henrik,

So here’s another odd thing. I noticed this morning that even though I’m not hearing audio I’m still seeing the audio meter in NCS moving (although it stays very low). I then noticed that every time I enable audio there’s a brief split-second of audio and then it’s gone.

Following this, I tried uninstalling and deleting everything from the ProgramData folder and then reinstalling and added the camera via ONVIF (which it apparently supports) and tried multiple profiles but though they all provided video, none had continuous audio (the two rtsp profiles had that split-second of audio still and the moving meters).

Still working to find a good time to give you access, but thought maybe this could help narrow down the issue.

One idea is to go back to the version where audio worked and see if it still works.
From your description, I am getting more suspicious that it is something on your computer. Have you checked all the sound levels, on/off and whatever else have to do with the sound.

Okay, you were absolutely right! The problem was on my end.

At some point in the middle of the night Microsoft unleashed their Creator’s Update and it did something weird with my sound drivers. I could hear 90% of my sounds/music just fine which made me unaware of the issue. I had uninstalled and reinstalled the older version of NCS and the problem was still there! It wasn’t until I went to play an old .wav file that the same problem happened (split-second of audio and then nothing). So I re-installed my audio drivers and restarted and everything is perfect.

Now, I do have one suggestion/request (maybe warrants a new thread?) to allow a selection of one camera as a permanent audio source, so that if you accidentally click out of a camera view or if you have multiple cameras in a single room but only one with good audio then that audio remains active as you flip through the cameras.

An issue I noticed is that if I turn on the camera audio but I click anywhere in that same camera feed (not even to a new camera) the audio turns off and I have to click the speaker icon again to enable the audio feed.

Thanks again for a great product!

OK fine, back on track again ;).
Thanks for the heads up with the Creator´s Update! That will most likely generate some buzz in the forum.
I put your suggestion on the list.
Your last discovery was quite annoying, I agree. Put that one on the bug list.