No Connection to Foscam Cameras

I am new to Netcam Studio and really struggling.

I have 3 cameras, 2 Foscam FI9821P and an FI8904W. Initially I tried connecting the cameras via their IP address and port, but no luck, I get timeout errors or device lost, never any connection.

All 3 cameras work via their own interface or via the web client.

I have tried to use custom URLs such as rtsp://user:password@IP address:port/videoMain but it doesn’t work. I have tried these URLs via VLC and had the same issues, so perhaps the problem is not with Netcam Studio.

I have tried disabling my firewall too…but still no joy.

Can someone give me a pointer?
Thank you

The Foscam 9821 is on port 80 or 88 by default for RTSP instead of the default 554 so try to use this as port:

rtsp://user:password@IP address:80/videoMain
rtsp://user:password@IP address:88/videoMain

If not please ensure that you have the latest firmware for them, they are pretty old however I have one 9821 and it works with both VLC and Netcam Studio but from what I remember depending on the firmware version, the urls to use may differ.

Hi Colin!
Welcome to Netcam Studio and the forum. The trick is to find the correct rtsp which is not always that easy. If the URL above do not work in VLC either the problem is not NCS. So we need to find the correct connection string rtsp …

When you add the cameras you can also do that by the tab Network camera. There you already have a template for FI8904W. Note that you have two ports to test, 80 or 88 for rtsp.
For the FI9821P you do not have a ready made template, but there is one for FI9821W. Test that one and see how it goes. There you also have two ports, 80 and 88, to test for rtsp.

Test this and report back how it goes.

Hi Steve,

Thank you for your reply. I have tried 80/88/554 no luck. I have also updated the firmware today…it made no difference.


Hi Henrik,

I have tried all you suggested… no luck. I feel like I am missing something fundamental…


Hm, yes I agree ;). So in the templates non of the jpeg, mjpeg or rtsp works?
When I search on the FI9821P i certainly get different results depending on firmware. It also seems that there is a FI9821P v2 of this cam which is ONVIF compliant.
Alternatively, if you can give us access to the cams I can check. I send you a private PM.

Foscam recently updated their firmware and in the process disabled the rtsp function, even if it was enabled beforehand… which is what happened to me. You might want to check the setting: Network => ONVIF and make sure it is enabled and the rtsp port is correct. Also make sure you set a static IP in the camera settings as the foscam cameras will try to renew their IP every 10 minutes! My foscam gets a new IP address every 10 minutes in my network unless I set it to static.

Foscam are absolutely dreadful with regards firmware and software for their cameras and their dedicated smartphone apps. The best you can do is set it as a dumb h264 streaming camera and then let some other excellent software (Netcam Studio) fill the void :wink:

Hi David!
Thanks for important info. However, in this case it was another problem that is solved. I have also heard that Foscam is a little bit to drastic when chaining firmware which is of cause very bad for their customers.
I think “set it as a dumb h264 streaming camera and then let some other excellent software (Netcam Studio) fill the void” is an excellent solution ;).