No sound in netcamstudio unless started with administrator privilege

in Windows 10 I noticed that I can’t get any sound when streaming a camera using netcamstudio client unless the NCS client is started with administrator rights. NCS does not even show up in the Volume mixer app. Sound in recording is ok, but its only when streaming that there is no sound.

Is there any setting I can set in windows to allow NCS access to the sound card without having to start it with admin rights?

All works for me in all three clients. You must be much more specific on how NCS runs and the settings for me to be able to test this.

I dont think I did anything special during installation, I installed NCS as usual, but the NSC server is set to run as a service and running under the system account. The Netcam Studio Client 64-bit is started manually using the shortcut that was created during installtion.

if I run the NCS client shortcut as a regular user, the NCS client does not appear in the volume mixer. If run the shortcut as administrator then it will show up in the volume mixer and I can hear the sounds from the camera. I can also specify to always start NCS client as administrator in the shortcut itself. Its not a big deal but it means I have to give the NCS client more privileges than I would like in order to use the sound functions. I am using Windows 10 Version 21H2 OS Build 19044.1466.

You are talking about a sound card. NCS do not need a sound card to work. For example in server systems that do not have sound at all NCS works very well also with sound.
NCS use “deep” resources in Windows and if you use a sound card that is an external resource in Windows and to access that you need admin privileges. Especially when running NCS as a service. If this is the case I can understand the behaviour of only allow an administrator to get sound.

Even if started the NCS client as admin after some time the sound stops working when I request to play the sound from a camera, and I can see these errors in the NCS client logs in reverse order. I am not sure how to interpret them. I get these unauthorized access error for all camera’s (Reolink and Dahua), whatever the model. If I restart NCS client right away the sound will start working again in the client for some time until it will stop working again.

Stop requested by Client
Removed 1 User(s) from Active Sessions due to inactivity
Exception Detail: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
at NAudio.MediaFoundation.MediaFoundationInterop.MFCreateSourceReaderFromURL(String pwszURL, IMFAttributes pAttributes, IMFSourceReader& ppSourceReader)
at NAudio.Wave.MediaFoundationReader.CreateReader(MediaFoundationReaderSettings settings)
at NAudio.Wave.MediaFoundationReader.Init(MediaFoundationReaderSettings initialSettings)
at NAudio.Wave.MediaFoundationReader…ctor(String file)
at Moonware.Controller.AudioStreamPlayer.AudioStreamPlayerRemote.WorkerThread()
Failed Request for http://delta1:8100/audio/3?resolution=0&authToken=45ca06b5-d5b7-47fd-87e4-d2808423f320 from
HTTP Error 401 - Unauthorized

Unauthorized access to http://delta1:8100/audio/3?resolution=0&authtoken=45ca06b5-d5b7-47fd-87e4-d2808423f320 from

New User connected: Anonymous from [28]

Play requested by Client

Do you use an external sound card?
If you use the web client is it the same behaviour?

The sound card is integrated in the motherboard.

But I noticed that the problem seems to be occurring only when NCS server is started as a service, When NCS server is started manually, there is no issue with the sound even after a long time.

I will get NCS server started via the task scheduler so I don’t need to use the service. that should resolve the issue for me

Most likely if you login NCS Service to an account with admin rights it will work since Windows mean that the sound card is an external resource. Double click on the service and in one of the tabs you can login.
When you start NCS server it always start with admin rights.
If you use NCS own audio server this will not be a problem.