No sound on motion detection and no sound from the IP Camera


I have the issues with audio from the IP camera, there is no audio stream from the camera while it is enabled on the camera it self.
Also there is no sound for motion detection when it is triggered either on the mobile phone or in the windows client. Is this an issue or something that is not implemented yet ?

Hi ObiVan!
The sound when motion is triggered is implemented. Go to Settings - Settings. There you have a checkbox for Play sound when motion is triggered. That will play a sound in the windows client when any cam is triggered.

What cam is it and how is it added to NCS? If you added using MJPEG there will be no audio since MJPEG to not include audio. To get audio you need to add with Custom URL using h.264 or mpeg4 that includes audio depending what the cam supports. Usually you use an URL like rtsp://… stream for this.

Hi Henrik,

Thank You for quick response ! the sound seems to be enabled from before so I adjusted the volume and then I hear only a short “pling” sound
a bit difficult to catch if You have some music playing in behind since this melody is to shoot. Would like to have an option for uploading own sound or add some more “alert” alike sound which have much longer melody, in this case we have at least an option to change the sound.

Regarding the volume I am using DCS-2330L (D-Link) and in the camera source I am using MJPG (Stream 2)… I have other options as well:
JPEG, MJPG and RTSP… but I know that camera supports the audio as I have another client on android for IP Camera and sound is working just fine.

are You talking about an custom url such as: rtsp://IP_ADDRESS:554/live1.sdp ? but what happens to the image quality when using rtsp protocol for streaming ?

Thank You for reply!

Sound will probably work fine with this camera, I use a DCS-2332 with audio 24/7.

in case there is no RTSP template ready to use for the 2330 in the list, give a try by chosing 2332, I’m pretty sure those 2 models are compatible and using the same approach.

Image quality you can adjust in the camera settings itself and you should have much smoother streams using RTSP rather than MJPEG.

Hello Admin,

thank You for reply!
i have now opened RTSP port in my firewall. Since I have two DCS-2330L ip cameras NAT-ed out on the same WAN ip address I have reconfigured the RTSP ports so the first camera still uses the default which is 554 and another is changed to 5555 and then both 554 and 5555 are now opened in the firewall and I have also changed from mjpg to RTSP in the camera source in NetCam Client and now I got the sound and MUCH better and smoother video stream.

Also tell me should I open TCP or UDP RTSP ports ? I have opened TCP for now and the autio works fine as far as I have noticed…

The only question that remains now is the mobile client (on android) phone, there is no sound on mobile phone client.

Yes, in order to hear the motion trigger pling you need to be in alert mode yourself. This is the only choice for the moment when running NCS as a service. If you run NCS in the mode NCS X then you can customize the sound and also on which cam using Rules, but that will not be heard in the windows client. NCS is getting more and more popular which is very since. With this comes also a rapidly increasing which and option list so the programmers will have a tough job ahead ;).

ok, I am running the NCS as a service and then I am using the NCS client for connecting to the NCS server, in this case I have to be comfortable with a “pling” melody :slight_smile: since I cannot change it when running NCS server as a service as You mentioned, but there is no point to run the NCS as X server (gui) even if we are able to change the sound melody since this will not work for the client as the client will still get the “pling” melody anyway so there is nothing more we can do except to support the developers which I already did by purchasing 2x 64 source licenses :slight_smile:

Thank You for helping !! Really appreciate it! and NCS components are very very nice designed and have very nice motion detection algorithm which is most complicated part here if You will get it 100% accurate without false triggers etc… so there is a big potential in this app but as You say it needs a lot of work to be an “complete” working solution… Of course this take a time to develop so be patient :slight_smile:

1 Like

I just saw now at night in dark condition the live video quality when using RTSP is horrible and motion detection produced almost 200 videos within an hour. Motion detection kicks inn constant when streaming over RTSP in dark condition, the audio is ok it works fine but the video quality is = 0 In day light the video quality is much better with RTSP then with MJPEG and motion detection does not kick in unless it is something moving in front of the ip camera.

when I switch to MJPEG in darg condition then motion detection is stable and does not kicks inn unless it is something moving in front of the camera.

I do not understand why this happens ?

What settings do you have at camera level ?

I have very few false trigger with the DCS-2332 and those settings:

here is the settings from the Camera: (audio_and_video) and (image_setup)

next image is coming in next reply because I got a message from the forum that new users can only upload one image at the time…

Thank You for quick responses !

Well maybe give a try to my settings, I cannot guarantee it will work but I remember that the denoise one helped pretty much.

Also I have noted much better compression with fixed bitrate rather than CBR (your Excellent preset).

I have just tried and motion detection stops triggering when using RTSP now when I have configured on the same way as You, but the problem is that stream is to “slow” and it “hogs” all the time… this is not an issue in day light as far as I have noticed… do You have best practice configuration for NCS ? regarding buffering etc… ? I am also having problems when video is recorded and then when I am playing that video it hogs all the time it is not an smooth video record… all of this happens only in dark condition and when using RTSP protocol…

Check the CPU usage, if it’s above 50% when decoding + motion detection + recording then it’s too much for your computer with the current settings. You need then either to reduce the resolution, or the framerate.

Also ensure that you use the default recording settings, the only thing there that you can do to reduce cpu requirements for recording is changing the preset to ultrafast, also eventually reducing the framerate.

On the camera you also use 4M fixed like I do ? Because when I put 8M it also starts to be a bit too much for my little barebone to decode.

CPU usage is around 15% when decoding+motion detection + recording …
I have just configured to ultra fast and the rest of the settings are default, and yes I use 4 MB fixed just like You did.

IP Camera have also enabled motion detection it self and camera is also uploading a motion detection videos to my NAS disk, and the video uploaded from the camera it self and the one NSC made upon motion detection are not comparable at all, the camera video is totally smooth no hangs and hogs while the one recorded by NSC have some kind of hogs and hangs while playing both in the picture and in the audio as well.

Not sure why this happens…

I have also received 180 videos during night when I used RTSP instead of MJPEG. In short words I have noticed that RTSP gives you much better live video quality in a day light then in the dark conditions, while the MJPEG gives you much better video in dark conditions then i day light… pixel stream and noises/pulsating is much smoother in RTSP in day light then in the MJPEG in daylight…

You’ll get much better results during night with higher-end cameras (Axis, Panasonic), those d-link are nice entry grade cameras and doing their job pretty well for the price but you cannot expect too much.

The fact of also enabling the motion detection and recording internally in the camera may also decrease the output. Because as soon as you have 2 connections to the camera you already notice that the streams are not as smooth and they probably give the priority to their internal recording task in this case.

Anyway, are you 100% sure that you compare the comparable. Is it really recording in 1920x1080 ? Because of course in NCS you’ll also get much smoother rate in 720p. I rarely exceed 17-18 fps in 1080p with my (higher-end) d-link so i don’t expect that your will give more. It’s however stable at 25fps in 720p.

Yes sure, I agree with You, d-link is entry grade cameras and do the job well for the price but we cannot expect much from them.
The main reason why I purchased d-link is to test all the possible features such as: motion detection, live broadcasting, day-night functions, illuminator functions, different resolutions etc… and then I can decide which camera will fit my needs…

But I am pretty sure that after all I am going to purchase an high end Axis IP fixed Dome camera model: P3367-VE… the only issue with this model is that it does not have build-in illuminator, but I can have en external mounted instead… This is an very good day-night ip camera so I will test it without an illuminator first as I have some light around the house which camera can use…

Agree with this one as well, I will try to turn off the internal camera motion detection and do some tests again…
It can be too much for the camera to first process an mail notification when motion detection triggers, then upload file to NAS and so let the NCS stream video in the same time…

Anyway, are you 100% sure that you compare the comparable.
yes I am…

Is it really recording in 1920x1080?
not sure what You mean with this ? the camera is 720P max…

BTW, can You implement an “select all” for video deletion in the library as pr today I am able to delete one by one only and it takes some time to delete 100-200 videos from the library… I cannot use the “SHIFT” for to select multiple videos for deletion… I can actually select the videos using the “SHIFT” but I can still delete only one video and not more at the same time…

Thank You for reply !