Playing video recording from library on iOS app show black screen

When I use the iOS app, goto the library, I can see all my recordings. I select one, the video comes up, but as it buffers and starts to. play, it just shows a blank screen.

What I have tried:

  • rebooted the server
  • re-installed the app
  • tried using landscape

One thing that does show the video sometimes is if I click on the video to show in Picture in Picture mode, but it does not always work.

Any help would be appreciated.

I assume live video works in the iOS App.
Test to use the web client. Enter http://NCS-server-IP:8100
Play a video from the Library. Working?
Has it been working before?
Is it a new installation on the phone/tablet?
What iOS version is it?


Thank you for coming back to me.

Live video does work in the iOS app yes.
I just tried the web client, and live video and videos from the library both play fine.

It has been working, for several years. I did move the installation to a new PC, but that was several months ago now, and it worked for several months with that change.

I have re-installed the app on the iPhone.

Version information is

IPhone 15,2
OS iOS 17.2.1
Framework 6.2.0

Netcam Studio Mobile 4.6.1
Netcam StudioX
CPU <1% Threads 40 Handles 1212

I have just tried it on my iPad, and the library videos play fine.

So it appears to be something with my iPhone.

OKay, I have no idea what has happened, but since i logged in through the web portal (or it could have been the iPad) to do the testing above, I have gone back my iphone, and all is working!

Apologies for messing everyone around.

1 Like