Please help me add my new D-Link DCS-2630L camera into your NetCamStudio software

I have the brand new 180 wide angle new D-Link camera, the DCS-2630L however I am unable to get the sound to work nor the digital zoom to work. It also has the ability to allow me to talk in it.

All of these amazing features of my new wifi camera would be great if one of you genius people could please help me figure out how to get this to work with NetCam Studio? Either there is a work-around or we will need some programming help.

I’m all ears. Thanks in advance everyone!!!


Hi Matt!
OK, when you talk about genius people I must respond. However, that do not imply that I can solve all your wishes ;). Usually, when a camera have a lot of nice and interesting features it use their own designed interface in java or active-x or …
You seems to have the video running by adding the cam by Custom URL with rtsp://…/play1.sdp. There you have the h.264 video and the sound? Talking to the camera and the digital zoom (1x, 2x 4x, …) are more problematic and is possible in the d-link program. But, you have an excellent continuous zoom function in the NCS windows client. First you manage to 1x1 of the cam. Pointer on the image and scroll and there you have the zoom. Left-click on the mouse and you can move around in the image. Nice!
Bidirectional audio is not implemented in NCS at this moment. Just listening.

Hi Henrik,

I’ve tried using rtsp with all stream types (JPEG, MPEG4, RTSP options and more) and it’s not working for some reason. Perhaps I’m missing something.


Once I get the audio working I’ll try out your zoom suggestion.


Just to clarify, video is working?

The video only works if I select a d-link camera that is similar to my DCS-2630L. In this case, I chose DCS-5222L. I’m trying to get the rtsp://admin:password@ custom URL to work but it’s not working.

A camera can stream various formats at the same time correct? Meaning I have a tablet connected to it with tinycam and I worked with the developer of that app and he added my camera to the list.

But yes, I love the rtsp idea but it’s not working yet for some reason…

Thanks for good info! Well, as usual it can be several things.

Yes, a camera can stream various formats at the same time.

Your URL rtsp://admin:password@ is correct with Stream Type: rtsp_tcp.
D-link is usually very easy to connect to …

  1. In the config of the camera at Audio and video -> Setup, the first stream, play1.sdp, set the resolution to max 1280x720 or lower. Do that help?
  2. When you use the template for DCS-5222L which video preset do you use (jpeg, mjpeg, rtsp 1 or 2)?
  3. Can you also test in Custom URL with set stream type to MJPEG
  4. If nothing helps can you forward the camera ports so I can reach the cam from here or if I can remotly work on your computer using TeamViewer?

When you add the camera with rtsp does it looks like this:

Concerning the audio I have unfortunately bad news. The cam use AAC (Advanced Audio Codec) which is not supported by NCS. AAC is a high-end codec for multichannel audio using high bandwidths. The codec is proprietary a must be licensed to be incorporated in a software. I have a D-link 942L that is 4-5 years old that also use AAC and it do not work with NCS. I am really amazed that D-link still use AAC since that is very rare in IP cams today. Instead they use open codecs like G.711 is one and there are others. Many cams can also choose audio codec as you can select video codec. There are surveillance software that have AAC, but they cost “a little bit” more. However, NCS have not licensed the AAC since it is not used that often anymore and cost money.

Good luck and you know where to find me ;).


Could we try the Teamviewer option?

Is there a way to private message people on here? Or else just email me at mattanfang at hotmail please and we can figure something out.

I’m watching our sick newborn son so sorry for the delayed response.

If we could link in via Teamviewer, I’m sure this is an easy fix for you. It’s over my head unfortunately.


I send you a private message for these things. Check in your mailbox.


I kept thinking it was emails. Sorry about that