Poor performance with Amcrest IP3M-941B


I’ve been away from Netcam Studio for a while but I’m trying to make my way back. However, we’ve “upgraded” one of our cameras to an Amcrest IP3M-941B and it’s producing really poor results.

I’ve set it up via ONVIF using the Main Stream RTSP_UDP with resolution 2304x1296 but the image is frequently blocky and hitching with consistent artifacting/banding across the image. Frame rate hovers around 15FPS and if I try to tilt or pan, the whole image smears and then reappears.

I’ve tried using the Main Stream JPEG (same resolution) and the image quality is much better but the frame rate drops to 1FPS.

Conversely, if I use the 640x480 Sub Stream (RTSP) then the transmission is fine although the image resolution isn’t what I would like from a 3MP camera.

We don’t have these issues when viewing the full resolution in Amcrest’s own app (which we’ve been using but hoping to get away from).

I had the thought to try setting it up just using the “Network Camera” tab (as that’s fixed some problems with Foscam cameras in the past), but this camera isn’t one of the supported cameras and using the only one in the list doesn’t give me the option for PTZ control (as the IP3M-943 in the list isn’t a PTZ camera).

So that’s everything I’ve tried. Any solutions you can offer would be appreciated.

The bad image you have is typical when there are to many errors in the data stream from the camera. The h.264 decoder cannot decode the data into correct images. The errors in the data stream are most likely caused by a low wifi signal that in turn generates these errors. The low resolution 640x480 use much less data and therefore it works. However, high res and high fps need a lot of good data to be transferred.
One way to solve this is to go to rtsp_tcp. TCP is an error correcting protocol which usually solves this problem if not the wifi signal is very bad. This works if the camera support rtsp_tcp.
After installation with ONVIF go to the tab for Custom URL. Change from rtsp_udp to rtsp_tcp. If that do not work you must improve the wifi signal or if using a cable it is a problem there.

Hi Henrik, thanks for the reply.

I should have mentioned from the start that the camera is already cabled. Cat6, if that makes a difference.

Regardless, I tried switching the camera over to TCP as suggested and the quality appears to be better, but I’ve lost control of the PTZ function.

If I try to switch back to UDP, the PTZ function remains disabled.

I tried setting it up without ONVIF, just using the custom URL and TCP from the beginning, and as before the quality and framerate is much better but still no PTZ functionality. Same if using HTTP or MPEG4 as the stream type and JPEG and MJPEG don’t connect at all.

Anything else I can try?

Check if the latest firmware is loaded in the camera. Is the cpu load of the computer running high?
When you add the camera with ONVIF there must be a profile for tcp together with PTZ. Using only Custom Source do not give PTZ.

The latest firmware is installed and the cpu load is not high at all. Netcam is at 15% and that’s only pushing the system CPU usage to 40%.

When I load the profiles for ONVIF, there is no TCP selection, only UDP.
ONVIF Profiles

In the camera’s own settings it is set up to use TCP (in fact there’s no other option in the dropdown) and within Amcrest’s own app it’s transmitting at a steady 10,000+Kbps.

Obviously the camera have tcp. Quite often you can change in the camera configuration what should be transmitted on MainStream and SubStream. TCP use more calculations and power in the camera why they try to avoid that. So log into to the camera and check.

Yeah, that’s what I mean when I said that it shows TCP but that’s the only option.
Amcrest TCP
It’s definitely transmitting via TCP but there doesn’t appear to be an option, other than custom url, to select that in Netcam Studio. Though I don’t know why it’s not seeing that protocol via the ONVIF profiles.

In the settings you can sometimes set encoding format. It can be h264, h264h, h264 baseline. It should be h264 or test h264 baseline.
Test if a template for Fiscam might work.

Thanks for the additional tips.

Unfortunately, changing the compression method to h264B or just mainline h264 didn’t change the quality issues.

Additionally, none of the Foscam templates would connect to the camera.

Any other thoughts? :thinking:

Sorry, but now I am out of ideas. The firmware has selected onvif profiles only with udp and that’s it.
Have you tested to change decoding parameters in NCS? Depending on processor change to hardware decoding. Remember to restart NCS after saving parameters to be on the safe side.

Download the onvif device manager and see if that gives another url for discovery of tcp profiles.

What is the date shown on your firmware? I used to have these issues until I upgraded recently.

1 Like