Possible bug identified

I have 7 IP cameras, which I can view on the Windows client, and by clicking on any one I can zoom in on it, which is great. However, if I give the user access to only some of the cameras, I am unable to zoom in on any after the camera I remove access to. For example, I have “user1”, who has access to cameras 1,2,3,4,6,7. That user cannot click to zoom on 6 and 7 (after 5, which is removed). “User2” has access to cameras 1,2,4,5,6,7. This user cannot click to zoom on 4,5,6,7. Using v1.95. I have done a clean install, and this happen on any Windows client connected to my server. Even the server itself (If I run the client on the same machine). Windows is fully updated too. Any suggestions, or is this a bug? Many thanks. @Henrik

Thanks. Have to check this.

1 Like

Thank you @Henrik :+1:

I created user1 and user2 as you described and some other users as well and it all works for me. I am not sure what you mean with “click to zoom”. Just move the mouse pointer to the video and use the scroll wheel. Do a left-click on the mouse and you can move the video image around.
Make sure that you have the visual C++ or later version installed from Netcam Studio - Network Camera Surveillance Software


Apologies @Henrik , I should have been more clear. When I have multi-view open on the client, I can single-click any one camera image with the left mouse button, and it makes that camera image fill the screen. Click it again and it goes back to normal. But it does not work for cameras as previously described. Could it be that I’m using Windows 11 on my main computer that runs the NCS server / service? All updates are in place. Thank you.

An update @Henrik . Just installed NCS on a windows 10 machine. Free version. Added two cameras. Viewed both. Could click to zoom all good. Removed camera 1 from the user account, so only camera 2 was there. Same issue, it wouldn’t maximise when clicked. Re-added camera 1, and both worked fine :slight_smile: So not an issue with Windows version….

I’ve send a video of what’s happening to Support :+1:

Thanks for the clarification. Yes you are correct. When in mode Multiview a left-click do not take the video to single view. If you manually from the dropdown menu select the video source it goes to single view. However, the zoom function seems to work in both views.
I tested some and for me it seems to be problem with indexing, but I am not sure.
I will pass this to our programmers for testing.

1 Like

Thanks @Henrik for getting back. I knew something was up :slight_smile: Not a massive issue though.

However, I was not aware of the possibility to zoom in and out using the mouse wheel! I like that! :slight_smile: