Problem starting server for first time

After a long time user of webcam7 i made the switch to netcam studio today. I first downloaded it on my everyday use laptop that has windows 10 and it worked perfectly. I then downloaded it to my windows 7 laptop that i want to have netcam studio on a permanent basis. However when i tried to start the server an error box popped up saying it failed to start: object reference not set to an instance of an object. And that is as far as i got i also tried to log on using the client and that failed as well . I have attached a picture
thanks in advance


Hi Eric,
Can you run webcam7 on the same computer as you want Netcam Studio to run?
Since NCS X Server do not start something is blocking it. Do you have an antivirus program running. That have cause problem before.

yes Webcam 7 works on that laptop I belive it was actually running when I
was trying to start studio I’m not sure if that could effect it? I do not
have any anti virus programs

They should not interfere with each other, but close webcam7 and test just to be sure.
Check if NCS can run as a service. Go to Services and start NCS there. Works?
Do you have latest :NET framework installed?

stopping webcam 7 gave me the same result also when i downloaded the studio it said i didnt have the up to date net frame and it downloaded it. when i tried to start studio as a service it failed with the message that is in the picture i attached

Hm, go to the Task manager and check if you have any processes running for Netcam Studio. If you have processes End them and try again. Something is missing or something is blocking. If this dont work do a clean installation of NCS 156. First Uninstall. Then delete whats in ProgramData>Moonware folder and Delete ProgramFiles>Netcam Studio. Install NCS again.
I will setup a Windows 7 here and see if I can reproduce this.

I can run ncs 156 on win 7 with no problems.
The message in the picture above you usually get when the ncs server is running. So check the task manager.