Problem with accessing web interface with cloudflare tunneling

Hi all ! I changed provider for my mobile internet and I don’t want them to sell me the fixed IP for accessing my network from outside. I went to cloudflare and installed a tunnel to my computer running Netcam Studio and my websites. All websites are working great and even the Netcam Studio login page works since i redirected my domain to 8100 on localhost. Now, when i try to log in, it doesn’t work. Tells me “login failed (undefined)”. Someone got any tips ? Thanks !

What changed in the setup from login worked to login not worked?
If you get the login page in the webclient check that you didn’t mark the checkbox for https on the webclient.
Make sure the server name/IP is the same in the web browser as in the webclient login.

Thanks for the reply. I went from a ISP that allowed me to use port 8100 to a ISP who is blocking all ports. Now, i installed tunneling from Cloudflare and I can’t manage to login. I see the login page and there is a Mixed content warning because the communication from Cloudflare is https and on my computer, it’s http. I try to put my NCS on https but it doesn’t seems to work…

I managed to make it work even in http. I used firefox… For some reasons, chrome blocked these connections from https to http. Firefox doesn’t…

Good you found the problem!
The security in especially Chrome increased drastically for about two years ago and now it do not allow mixed conrent, http and https. More info in the section guides & tutorials.
Firefox allow mixed contect, so far. IE11 also. Edge sometimes work if configured to run in IE mode. Easiest is to stay on http.
Run NCS in https using self-signed certificate is possible. However, most devices to not allow self-signed certificates any more so a commercial certificate with http or domain name verification is recommended.