Problems adding unlisted IP camera

So I have this GUANGZHOU IPCAM, as identified by ONVIF Device Manager. Everything appears to work in ODM such as fetching profiles etc. and I can view the video stream in VLC with the URI rtsp://a@ (where “a” is a passwordless user I created for simplicity).
However, no matter what I try, I cannot get it to connect in NCS.
In the ONVIF Source option, I can find the camera and I enter the (admin) username and password but clicking Get Profiles returns nothing and the error in the log is as follows:

Error retrieving Onvif Profiles on
Exception Detail:The header ‘Security’ from the namespace ‘’ was not understood by the recipient of this message, causing the message to not be processed. This error typically indicates that the sender of this message has enabled a communication protocol that the receiver cannot process. Please ensure that the configuration of the client’s binding is consistent with the service’s binding.

And then again but with /Media in place of /device_service
So, no luck on that front, I tried the custome url option and, as mentioned above, the url rtsp://a@ works just fine in VLC but in NCS I get nothing and the log simply says:

Starting Source(2)
Stream Event received [DeviceLost]
Connection with rtsp://a@ has been lost. Will try to reconnect in 1000ms…

No matter which Stream Type I try… Decoding settings are set to Software_VLC (also tried _Internal).

I had no issues adding an unlisted HAUCAM using rtsp.

Any thoughts/suggestions welcome.

Hi Matt,
For rtsp the stream type should be set to rtsp_tcp. But, I am getting a little suspicious abut this passwordless a you are suing. In NCS it should be rtsp://username:password@… If there are no need for login then rtsp://IP… If username and no password rtsp://username:@. I think it is here you need to make it correct.

For onvif you write that you enter username and password to the passwordless account? A complete account with username and password maybe solves it?


Hi Henrik,
I probably didn’t make clear that when doing the onvif part I was using the “admin” account on the camera, which does have a password.
I also tried the admin account, with password, on the rtsp customer url and, although that didn’t work, I just tried your suggestion of the colon on the account with no password and, voilà!, it worked… Must be the one combination I missed.
Thank you, an excellent piece of software and excellent support. I will certainly be inclined to upgrade to the paid license, even if I don’t need the extra features.

Excellent! Small details :wink: Looking forward to your enrollment!

Regarding this error it seems to be a mismatch between what Netcam Studio expects as answer and what it receives. Normally our logic should be almost the same than the one of ODM but maybe I have missed something…

Unfortunately this is quite tricky to investigate / fix without having physically the cameras on my own network.

Understood. Not a problem now that I have it working with the custom url. But if you want me to prod and poke and extract any details/data from the camera that might help you for the future then let me know. FYI, it only cost 20 UKP on Amazon, a bargain…

Extracted data won’t help in this case however if you can expose the onvif web service available over internet maybe I can diagnose remotely now that NCS allows typing in any custom onvif url.

Sometime it doesn’t work (devices accept only local ips) and sometime it does so if you can get this to work please send me the external address to reach your /device_service web service as well as credentials in PM.