Problems with Re-connection after Restart



I’ve had a fair few issues… They seem specific to Camera’s we’ve bought… however They work fine in VLC

Initially I was getting what i’m calling keyframe drift… where the bottom half of the screen appears to slowly drift to the Green Spectrum… Changing Decoder to VLC has fixed this…

However now when we reboot the server it fails to connect to the camera… It connects to a foscam camera just fine… but these ones it doesn’t… I have to login to the server click edit the camera settings and then just click save to force it to reconnect… which it does and then it’s all good…

At the moment we just avoid restarting… However long term this just isn’t going to work… I was planning to buy a license as I’ve got 3 more cameras to put in… However I emailed support and have never heard back at all… So I’m attempting contact via the forums then i’ll give up and go use something else…

I did like your product due to it’s comprehensive feature list and that it’s well written… my coding knowledge tells me you thought this software out before getting into it… However an intermittent security software is no security at all…

I haven’t even tried all the features yet because I’ve been battling these issues


Hi Ryan! I agree, quite anoying. I am just leaving for the weekend and back on Monday morning. I hope you can wait until then. In the meantime can you support me with what cameras, “these ones”, you use and if they are added to NCS using Template or Custom URL. Are the cameras set to DHCP or fixed IP? What operating system do you use?
Have a nice weekend!


Camera’s are almost noname Chinese - But found this on the site : TinoSec - YN-IPC-BT511S-P-20-1

Camera’s have been set Statically, and are connected via a Custom URL
of the order rtsp:///user=&password=&channel=1&stream=0.sdp
It’s currently running on Server 2016 Release Candidate 2, But doubt it has much to do with the Connection Issues

Thanks for getting back to me… Hopefully we can get these issues resolved


Thanks for info. The rtsp seems a little bit strange to me. When adding a camera in Custom Url the other tabs musty be empty and in Custom URL use rtsp_tcp and the URL

The last rtsp is the standard for NCS, but the first one might also works depending on camera. The missing part is the ipnumber. The OS is of interest since is it important to use the latest .Net framework 4.5.2
Please report back how it goes.


I have the same problem with 2 of my Cam’s.

NCS (ver. 1.2.8) is running on a windows 10 with .NET framework 4.6.1 installed (if you have same problem and need to find out your .Net framework version look here: Link).

Cam1: rtsp://Username:Password@ipnumber:554/0
Cam2: rtsp://ipnumber:554/user=YYYYY&password=XXXXX&channel=1&stream=0

I belive that Server 2016 Release Candidate 2 too has .Net framework 4.6.1 and Mircrosoft say that it should be work with with .Net framework 4.5.2. I will how ever be testing this by installing a NCS ver. 1.2.8 on a windows 7 PC and adding my cam’s. Hope to bring news monday


I just discovered problems also with ncs128 and nf4.6.1 and w10. It seems to problem with WCF. Any new info?


.NET Framework 4.6.1 is standard on Windows 10 and is running 24/7 on our test system without any problem so it’s not the reason of the problem.

There is no known / reproductible problem either with Windows 10 or .NET 4.6.1

Maybe a Windows Feature is missing. I am running Windows 10 PRO N, are you running another edition ?

Under turn Windows feature on and aff, please verify that you have the advanced .NET Features as on the screenshot below:

Now I don’t remember if this is default or if I had to add it manually but I think it was default.


Keyframe drift (using the internal decoder) should hopefully be fixed in 1.3.0 and I will try to release it can be released this month.


Also running 10Pro. The settings above are default. However, after some restarts for other reasons it seems to be working fine now. The classical Windows trick with restarts still works ;). Hopefully it is solved for the guys above also.