PTZ Not quite working correctly... Movement won't stop, zoom doesn't work at all

I bought a cheap-o PTZ camera off Amazon, supports ONVIF. Maybe it’s just the camera, and if it is, I can live with it, but when I use PTZ buttons, it the camera moves in the correct direction, but doesn’t stop until it reaches the limit of it’s motion. I can get around this by clicking the zoom + or - (which doesn’t work at all, even though it has zoom capabilities) But I assume it’s sending the camera a “different” command to interrupt the motion. If I click the same directional button again, nothing happens, just keeps moving. If I click a different direction, it starts moving in that direction, but again, doesn’t stop until it reaches it’s limit or if I click one of the zoom buttons. The software that comes with the camera works just fine, I even tried some other apps on google play that also work, so it’s something with Netcam Studio (not sure what, though) I tried both PTZ options (relative and continuous) and both behaved exactly the same. It does this using the mobile app (android) and the client software for Windows. I ordered a couple other different types of PTZ cameras, I’ll see of those behave the same way, or not. Is there anything else I can try to get it to work?

Hi,
As you probably have read in other posts there are a discussions about ONVIF PTZ. We have tested on Hikvision, Reolink and I actually just tested on one of those cheap cameras on Amazon and all works great. Is it the same behaviour when you test the camera from the web client? Can you give me a link to the exact camera on Amazon that do not work.
-Henrik

Thank you, here’s a link to it on Amazon: https://www.amazon.com/gp/aw/d/B08L3KS4FN

Ohh! I didn’t think about testing it from the web client, I’ll try that and report back.

Yeah, exactly the same behavior on the web client, too. I can give you the address/login so you can see, if that’ll help.

Yes please. Send a PM.
Also, please check in the tab for Custom URL and send me the URL in the Address field. Then I can see if our cameras use same or different electronics.

Thanks for the link. It’s very much like the one I just tested.
I assume you connected it with wifi. The camera can also be connected by LAN cable. Can you do that and install it with onvif again. It will have a new IP-number.

The camera 4x zoom is only digital and is handled in the custom App. ONVIF works only with optical zoom in the camera.

Okay, I understand about the zoom - not a big deal anyway. I have the camera hooked up to a cable, verified in the camera app that it is indeed connected (not through wifi) - I re-added it to netcam, and was able to login and view it - the motion behaves the same way. I’ll PM you the info to login and the url.

oops… “Sorry, you cannot send a personal message to that user.”
Is there another way I can PM you?