RAM usage starts low, increases slowly, NCS crashes

I’m running the NCS Server (v on Windows 10-Pro with 8GB RAM. I use 16 cameras and this is a special purpose PC (i.e. the PC is only used for NCS).

I’ve used this setup for years with no problems.

In the last 2 months NCS crashes after about 10-15 hours of operation. I see that the RAM used starts at about 2.8GB and climbs slowly (about 0.5 GB per hour) until the application crashes.

What I’ve tried:

  1. I’ve changed server encoding and decoding setting - no change, problem persists at the same rate.
  2. I’ve shutdown motion detection on all the cameras - no change.
  3. I did a complete NCS uninstall, scoured the Registry for NCS detritus, and a “complete” reinstall, camera setup (all 16) and the problem persists - no change.
  4. I searched the forum but couldn’t find any answers (except Henrik’s recommendation re. decoding buffer size (#1 above).
  5. I’ve written this new topic.

Thank you for your attention.


I assume it´s the clean installation explained in the guides and tutorials that you have done.
I assume you have tested that it´s really NCS that generates this. Start the web client and in the menu go to System and Performance. There you can see how the memory is used. Also Handles are of interest if they are sort of on the same average or if the value is constantly increasing.
Can it be a camera that gone wild and generates a problem with memory. Can you turn off 8 cams at a time and see what happens.

You are GOOD!
After my earlier inquiry, I turned off all but one camera. The memory usage was stable.
I am currently in the process of adding one camera at a time and checking status after an hour or so.

Soon, I hope to find the camera that has “gone wild”.


Henrik- You are an amazing person! Thank you for your always EXCELLENT service!


1 Like

He he, thanks. Please give us an update what happened.

I’m sorry for the long-awaited update. :^)

I dumped Bit Defender (BD) on that PC… and went on to using just Windows Defender and everything worked fine.

After months, I was trying to solve a new NCS problem so I re-installed BD. For some unknown reason, NCS continues to work fine.