Rebooting server lost settings

I’ve never had this issue. Whether it be a planned reboot, or a hard reboot (loss of power), all settings and sources are as they were before the reboot…

I understand that you haven’t. I have, and am attempting to recreate the issue.

Further testing has confirmed that using NCS 1.7.2 I lose the following settings after a reboot:

  • Motion Capture settings
  • Time Lapse settings

I have tried the following:

  • Editing source details then going to settings, making a setting dirty, then saving
  • Closing the client using the X
  • Closing the client using Logout
  • Closing the client using Exit

Each reboot of the server was done at least 2 hours after adjusting the NCS settings.

Let me know if more logs or tracing is required.

Further testing confirms the issue is not consistent.

After ten days of uptime (16-May-2019 - 26-May-2019) the server was rebooted. The settings for notification by email were previously enabled, then turned off. After the reboot the email notifications were enabled.

Action taken:

  1. Logged into server
  2. Reviewed status of each source
    • Lost Timelapse settings on source 2 - updated
  3. Disabled email notifications
  4. Made a setting dirty to allow settings to be saved to see if this forces the client to update the server settings
  5. Confirmed settings were updated in Event Log

Will report back after the next server update.

I have similar problems, sometimes the settings are reset to some previous one. Here is some example.

Note #1

  • My Camera Nr.2 has been set weeks ago to continuous recording with 5 min timelimit
  • cca two weeks ago I modified it to motion detecting, it worked as expected
  • some days ago I just noticed there is no motion alert from that camera, but I have lot of recordings
    Settings are restore to previous one!

Note #2
I switched on push notification just for curiosity. Some days later I switched off, because I don’t want use this feature.
Some days later I get push notification again!

Note #3
I set up detection zone as my needs.
Today I had lot of alarms from my outdoor camera (it sees some trees, and weather is very windy) - detection zones are forgotten completely!

When I have started to test this program some months ago, I experienced similar strange things. But the program has been worked well for long weeks. I don’t know what happens when this happens… maybe windows automatic restart after update is the reason.

Otherwise this PC is a dedicated machine, it is running 7/24, no switch cycles, no restarts, no other interrupts.

NCS is running as service, I manage it via NCS Client (from other PC)

+1 request
Could you add a “Clear all” button to library?

Yesterday my windows has been updated, restarted.
(last restart was weeks ago)
Some settings has been restored to previous state.

We are working on this.

1 Like

I amended settings on 4 sources to change the timelapse from 1 image every 30 seconds to 1 image every 20 seconds. I quit NCS by clicking the close buttom (top right, standard window). A few days later, I rebooted the server. The settings had reset to 1 every 30. I changed again to 20 seconds, and this time quit NCS using the “Quit” option (click on application X, then click Exit).

I just rebooted the server and confirmed that the settings are now at 20 seconds.

This is still inconsistent, though.

Maybe next Easter brings the fix. The development cycle is very slow/rare.
(This is the reason why I don’t purchase the NCS yet.
“Receive free upgrades during 1 year” - this is a joke… What upgrades???)

Hi wacher,
It’s in the process. People who bought a license for 4-5 years ago still receive upgrades and support. However, since you haven’t bought a license yet I really don’t see why you are complaining. There are other softwares out there that you can buy.

Any idea when the process might update the defect we’re discussing here?

the webpage says

  • “Receive free upgrades during 1 year” and
  • “You are eligible for free upgrades including major versions during 1 year following your purchase.”.

If this is not true, please amend these and please don’t blame me.
If there is no (short) time limit for updates I will buy the software.
Thank you for your kind advice, but I don’t want any other software because this is best for my needs.
But after all I think shorter time between updates would be better (see this half year old(!) thread, this bug is very annoying I have to check every day an unattended system).

Hi guys,
I am running and testing NCS version 1.8 just now so well before next Eastern I hope :wink:


Is there any news about the new version?

Yes, news is that it´s under test and evaluation.

Excellent news. I can wait until then. Keep at it, Henrik!

Dear Henrik,
Could you publish the new build?
If you can’t do that then could you explain to me how can I be sure about settings were saved and persistent?
I had to recreate 12 rules which gone since last week…

We are on the way to finalize testing of the new version, but it will be another week.
However, interesting for me is how actually this can happen. What you say is that you create rules and without restart, reboot or whatever else and the computer and NCS runs with no interruption the rules are gone?
Can you please describe what rules you create so I can setup them here on my system.

Sorry if I wasn’t clear, but I didn’t said the PC was uninterrupted.
Last week I tried to integrate NCS into (Home Assistant) as motion detector via HA’s web services. Therefore I created some rules to call an alarm.cmd if a motion is started or ended.

PC has been restarted at least 2-3 times since that.

Today I would like to contine my work but the rules are missing.

Feature suggestion:

  • Duplicate this rule (in order of create similar rules easily)
  • The “Eventtype” is shown in Rule Manager table, “Event source” should be shown too. If I have a lot of rules overview was easy.
  • The %sourceId should be evaluated and passed to called app. Without this I can’t use "motionStart on any source call ‘alarm.cmd %sourceId on’ " because I can’t tell which camera has been activated. I have to create a rule for every single camera to call “alarm.cmd 1 on”, “alarm.cmd 2 on” and so on.

Please correct me If I’m wrong.

For the “lost Rules”. When you have created the Rules and they are Enabled go to Settings and click on the save icon.
Now Rules or changes in Rules are saved immediately on disk.
Can you please keep an eye on this and report back how it goes.
As for the suggested Features I will be back.