Recordings freeze


Hi there!

I’ve noticed that all my recordings are freezing after a couple of seconds from start. You can see it in attached video example - look at the seconds counter in right bottom corner.
Example video

Some specs regarding my installation:
win10 1803
Recording settings:

  • Video Quality: CRF 20
  • 30 FPS
  • Preset: Fast

Videos are made only when motion detected.
Average CPU usage during recording: 68% (NCS 49%).
No other CPU consuming apps launched.

Could you please help me to identify and fix the problem?


Most likely the cpu load is high. This depends on many things.
-the 30 fps. If that is what you read in the bottom right corner in the video it is what the camera deliver to NCS. If you also use 30 FPS for recording the video I can imagine this. Settings - Recordings - Frames per second. What is that setting?

The resolution of the camera and how many cameras?
What CPU do you have?

Most like you solve this by decreasing the FPS from the camera, decreasing the Recording FPS. Using 30/30 FPS is very seldon needed if don´t have a cat that runs at the speed of light :slight_smile:
We can start here :slight_smile:



Hi Henrik!
First of all - thank you for your reply!

Here are the answers to your questions:

  1. 30 FPS - it’s the value that I see when I watch stream (or regular recorded video) from the camera. By the way watching the stream in realtime is always flawless.
  2. Settings - Recordings - Frames per second: also set to 30 FPS
  3. Only one camera, Full HD 1920x1080
  4. CPU: Intel i5-7600

Of course I can try to decrease the FPS, but it worked like a charm before. I don’t know what had happened (maybe after the NCS update, not sure) but one day all the recordings became like the example.



Hi again,
The classical “worked as a charm before” makes me suspicious :). Only one camera with that cpu should not be a problem. Question is if it is the playback that is the problem? If you use VLC now try to use another player. Do you have any old recordings that you know worked before so test with them.

Decrease the setting for Recording of FPS and test.



Spent around an hour trying and experimenting. Several settings, players, other stuff - no luck.
Ended up with complete reinstall of NCS, including manual deleting NCS-related folders from c:/ProgramData, %localappdata% and %appdata%. After installing fresh version of NCS again it works wonderful again, without any freezes.
My main idea was that there could be some conflits with config files from older NCS installations, because it was not the first NCS build on my PC, I use it for more than a year (and love it :slight_smile: ) and always try to have the latest version available.
I will check the situation for couple more days and text you in case of issues.
Anyway, thanks for your support!
It’s nice to have this place where users can report about thier concerns and get such a rapid reply :slight_smile: