RTSP Stream not showing


I have 2 DVR units on site. I am able to access the video stream via VLC. but when I try to access them on NCS it shows “No stream to display”.

I have tried all the stream types, same result. anything else I can try?

Here is a shot of the log:


EDIT: Added Screenshot of log

Hi again! A predefined template would have been very nice. Just kidding ;). From earlier you seems to quite good at this so I am not sure what to add. I have seen this before that it works fine in VLC which then it should work as well in NCS. From the image above it connects to the camera, but no stream is received. Hm, … Can you write what camera it is and the complete rtsp. Any difference between running NCS X or NCS as a service?


It is a Hikvision DVR (DS-8104HFI-ST). I access the stream on VLC with: rtsp://view:view@IP:554/ch1/main/av_stream

I haven’t tried running it directly in a client. Only via the server service.

That was the DVR. I was looking for the name of the camera that you try to connect to NCS.


I don’t connect to the camera. I connect to the DVR and get the stream from it. The camera is a Coax Samsung, so can’t connect directly to it.

I want to add the stream from the DVR to NCS.


I have been trying to find info about this, but it is not that easy. Obviously, NCS do not find a stream using that rtsp even if VLC does. Did you get that rtsp from the manual or? Is it h.264 or mpeg4 ?
I found this one:
Can VLC analyze what type of steam it is?
Why do you need NCS when you have the DVR with all the functions built in?

In NCS’s settings, did you try to switch the decoding mode from BUFFERED to VLC ?

It should in this case rely on VLC’s library to do the decoding.


@Henrik “Why do you need NCS when you have the DVR with all the functions built in?” Because I want to give the security manager access to the the 2 gate cameras, we will be putting up IP cameras there in this year so this was just a nice to have this in the meantime. As for the DVRs… why use the DVRs when we have the much better NCS? :grin:

@Admin No i have not as this is a live server and my test VM took a nosedive. So will play around once I have a test VM up again. Especially since there is a new version out. :slight_smile:

Excellent answer! :slight_smile: .