Rule Manager doesn't work on Global Variable

I have tried to make a rule, that starts recording on a valuechange in a global variable. The global variable is a remote JSON based variable with a value of 0 or 1. On 1 the recording should start and on 0 it should finish. But the rule always shows 0 executions. I have tried the operators = and >. Please check if this is a bug.

Are you running Netcam Studio X (server) or Netcam Studio as a Service?
Can you also specify what you are doing so that I can recreate the situation.

Netcam Studio runs as Service.
I made the global variable like this:

The value is always correct.

Then I made the rule like this:

But, as shown, the rule executes not when the value is 1.

Have you tested this in NCS X (server)? I am asking because Windows limits what can be executed when running as a Service.

Now I have tried it in NCS X. But the result is the same.

Thanks for info. This is beyond my knowledge so I am forwarding this to our developers.

Issue confirmed. Netcam Studio doesn’t request variable value for Global Rules.
update: issue is fixed. Will be available with the next release.

1 Like

Now I have waited about 6 weeks the update is coming out, now it is released but the issue is still there :disappointed:
The Rule Manager doesn’t react on the change of my global variale anyway.

Hi! We check into this asap. @Steve


The problem that has been found was that the remote variables where not refreshed if they were not displayed / used in the overlay. This should be fixed now.

Since 3-4 weeks there have been plenty of releases to test / review in this thread:

So yes now it’s too late for 1.3.5 since it has been released officially in case still doesn’t work.

I will however log a new issue and ask this to be tested / reviewed again.

Now, on it works fine. Thank you.

Thanks for reporting back!