Setting up a TP-Link NC230 cam and D-link DCS-936L

I am fairly new to Netcam Studio. I had no problem getting my old Logitech USB webcam to work, and I then added a D-Link DCS-936L cam, it was not in the list,but I got it to work perfectly with the next higher model number choice DCS-942L. I tried to get a second one, but they were not in stock, so I figured I would try something else and got a TP-Link NC230. Since the other two worked so easy, I just tried to plug away, but with no luck so far. I can view the cam from Internet Explorer, so I know I have it up and working on my network.

The cam stream is H.264 1280x720 VBR at 10 fps. I do not see any choices in the cam setup page to change it to MPEG or (m)JPEG.
The software or documentation I have found does not list port numbers or URL’s

Thanks for any help here

Hi Scott and welcome to the forum.
Well, plug away, is not always that easy ;). Some camera manufacturers like D-link have a very good documentation how to connect to their cameras. You can get that info in the configuration of the camera. Some manufacturer could be much better on that. However, take a look in the configuration of the camera if there is some interesting information. If not I have some tips for you to test:

-When adding the camera in NCS go to the tab Custom URL.
-The camera deliver HD using h.264 so set Stream type to rtsp_tcp
-The million dollar question is the URL and here are some suggestions that you should test:


Good luck,

Thanks a lot. The first URL string “rtsp://username:password@ipnumber:554/h264_hd.sdp” with my information entered for the user,pswrd,and IP works in VLC. I will try it in Netcam Studio in the morning.

Excellent, thanks for the feedback. It helps other users with that camera.
I am sure it will work in NCS.

I got it up and running on Netcam Studio last night, the same URL worked.
When it first came up it had a red band across it, “Unlicensed Stream” or something like that, but it went away after a couple minuted and I have not seen it since.

Thanks again for the help.

My next step is setting up my notifications and such.

Good! First 2 cams are within the free license. From camera 3 and up you will have this red banner.
Need assistance you know where to find me ;).
Good luck,

Hi, i have the same cam as u, the 936L. thought i might ask if u are able to get sound with yours? i did as u when chosing the cam but sadly no sound for me.

Hi Andreas,
Start with the easy way first. Make sure that you have enabled the Microphone in the Audio setup in the camera.
If that do not work the next step is to Add the camera using the tab Custom URL.
-Set Stream type to rtsp_tcp
-Set the URL to rtsp://username:password@camera_ip_number:554/play1.sdp

In the configuration of the camera you can set the resolution for play1.sdp. Default seems to be 1280x720.


Thanks, that helped :slight_smile:

Using the same camera to do the same thing … D-Link DCS-936L. I can get a stream to a web browser by using https://ip_address:80/video/mjpg.cgi from the camera. I cannot use this string in Netcam Studio … it simply times out and refuses to connect. I have tried experimenting with the rtsp strings above, and while those spend a greater amount of time “connecting”, they eventually time out and fail. What am I doing wrong here?

There is a predefined template for this camera in NCS so when you add this camera to NCS use the tab for Network Camera.

Thanks! That was where I started. It didn’t work unfortunately. It simply won’t connect. I can see the camera feed in the little D-Link app they have for mobile devices, but obviously that isn’t going to help (other than prove that the camera works, I guess.)

D-link cameras are usually very easy to work with, but …
according to specifications the camera support h.264, mjpeg and rtsp.
-do a factory reset of the camera if some parameters have changed.
-use the latest firmware.
Try this in tab Custom URL:
-set stream type to MJPEG
-set Address to
This gives no audio.

Here is a picture from the manual for DCS-936L where you can see the different URL´s


In tab Custom URL it should be

play1.sdp or play2.sdp or …

Thanks, Henrik; sadly, none of these appear to work. I’m just stumped. None of them will connect - they simply fail over and over. I have factory reset the thing at least 5 times and started from scratch. When I try and configure from the “Test Camera” connection in trying to use the template, it times out. I am so frustrated … the only reason I bought this little camera was that several folks had reported success in getting streams from it into Webcam 7/Netcam Studio. I honestly don’t know what my next step is and I’ve been doing this a really long time!

Can you connect to the camera from a browser and when you go to SETUP and Audio and Video you should see it as in the picture above? In the browser just enter

Post a picture here how the template looks like when yo have entered the parameters.